Tips and Settings issues (vanilla)

Discussion in 'Civ4 - Bug Reports' started by marstinson, Aug 4, 2008.

  1. marstinson

    marstinson Chieftain

    Joined:
    Jul 14, 2008
    Messages:
    68
    I've reported this issue before, but am still hoping that someone can point me to a fix.

    The biggest problem is the "Sid's Tips" do not consistently work throughout most of the game. In the Diplomacy screen, for example, I can tell that one civ is annoyed with another, but can't tell why. If I go back to the main game screen, I'll get the tips that tell me why they're pleased/annoyed/etc with me, though. After completing production or research and being asked to choose the next build or tech, sometimes I'll get Tips, but usually not. Along those same lines, sometimes my mouse scroll wheel will work for scrolling down the list, but usually not (it always works for zoom, though). It's not a game-breaker by any long stretch, but it is certainly annoying. Oddly, this problem does not show up in BtS; just in vanilla Civ4.

    I'm running build 174 for vanilla and 317 for BtS and the only mod in vanilla is the HoF package, which only loads for HoF games (I think). For BtS I'm running Solver's Unofficial Patch, but nothing else that I know of. I had installed Bhruic's patch back when I was at 313, so it may still be there if it didn't get overwritten by the 317 update.

    A separate issue happened this morning. I cleaned out my saved game directory (regular saves, quicksave, and autosaves) for vanilla. When I started a new game, most of my .ini changes (like no intro movies and asking whether to be fullscreen or windowed) had reverted to their defaults. Should this have happened just from deleting saved game files? I know that some settings (map size, game speed, etc.) get written to the .ini as hold-overs from the last game started, but the others are just puzzling.

    Thanks for any help or info that y'all can provide.
     

Share This Page