Trying to create shortcuts to individual mods on Steam Deck - what am I doing wrong?


Mar 18, 2024
On my Windows desktop I have shortcuts set up to launch individual mods. You know, target Steam, arguments -applaunch 8800 "mod=\Magister Modmod for FfH2". What I'm failing to do is replicate this on my Steam Deck, because sometimes I want to jump right into BTS, others I want Fall From Heaven.

So far, I've gone into desktop mode, Steam, created a desktop shortcut to civ 4 BTS, which results in a .desktop file which launches Steam with the argument:


AoE is my test case here, so once I add that to Steam, open its properties, and to its launch options I add "mod=/Ashes of Erebus" (including quote marks. I try to run that just launches vanilla BTS. I've tried back and forward strokes to no avail.

What's infuriating me is that if I go to the 'normal' civ 4 entry in Steam and add my mod to the Launch Arguments, it works fine. I've tried this with BAT ("mod=/BAT Mod 4.1") and Ashes of Erebus ("mod=/Ashes of Erebus") and this overrides anything I try to do with the custom shortcut. That'd be fine if I only ever wanted to play one mod, but I'm likely to put 3 there (BAT, AoE, Magister) and I'd like a lovely little steam entry for 'Fall From Heaven II' for example.

It's like any custom shortcut I add to steam just ignores anything after the rungameid 8800. I've even tried setting the 'start in' to the Mods folder, nothing. Civ 4 can start any mod on the Deck, but I just...can't pass the argument on to the Steam launch from something else like I have on Windows.

If I try to add the BTS .exe itself to steam, it just fails to launch anything.

What am I missing?
Don’t launch 4 from steam library. Use the bts exe and create mod shortcuts from it
Top Bottom