• Civilization 7 has been announced. For more info please check the forum here .

A few serious multi-player bugs...

CloseTheWorld

Chieftain
Joined
Sep 20, 2010
Messages
4
<rant>

I've encountered some very annoying bugs while playing online with a friend.

- There doesn't seem to be any way to save the game! The save button is available in single player, but it is absent in multi-player. Anyone else notice this?

- I experienced a major graphical error. It kicked me back to the loading screen, and once loaded, there was now a giant vertical monstrosity blocking my view. As a result, I exited the game and tried to reconnect, which brings me to...

- Upon restarting Civ, I used the Steam interface to rejoin my friend's game. After connecting, it took me to the new game menu. Both of us were listed, but our civilizations, difficulty, teams, maps, etc. had all been reset. My friend, still in the original game, got a notification that I had joined, but I was forever stuck at the starting game options screen. There went 200+ turns. And there's no way to save!

- Many, many disconnects and crashes on my friend's end.


</rant>


Any ideas or feedback?
 
Haven't tried yet but the multiplayer was supposed to use the autosave feature with no manual save.
 
Top Bottom