1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Adding new specialist - city view UI problem

Discussion in 'CivBE - Modding Help & Mod Creation' started by Starrynite120, Feb 20, 2016.

  1. Starrynite120

    Starrynite120 Prince

    Joined:
    Jul 15, 2015
    Messages:
    472
    I added a new specialist and created a new building to put it on. When that building is put in a city no other buildings show up in the city and its description is for the headquarters. I also can't assign citizens to tiles. When I removed the specialists from the building there was no issue. Here is my code

    Code:
    
    	<Specialists>
    		<Row>
    			<Type>SPECIALIST_PURITY</Type>
    			<Description>TXT_KEY_SPECIALIST_PURITY</Description>
    			<Strategy>TXT_KEY_SPECIALIST_PURITY_STRATEGY</Strategy>
    			<Visible>true</Visible>
    			<IconAtlas>CITIZEN_ATLAS</IconAtlas>
    			<PortraitIndex>4</PortraitIndex>
    		</Row>
    	</Specialists>
    
    	<SpecialistYields>
    		<Row>
    			<SpecialistType>SPECIALIST_PURITY</SpecialistType>
    			<YieldType>YIELD_FOOD</YieldType>
    			<Yield>3</Yield>
    		</Row>
    		<Row>
    			<SpecialistType>SPECIALIST_PURITY</SpecialistType>
    			<YieldType>YIELD_PRODUCTION</YieldType>
    			<Yield>3</Yield>
    		</Row>
    		<Row>
    			<SpecialistType>SPECIALIST_PURITY</SpecialistType>
    			<YieldType>YIELD_CULTURE</YieldType>
    			<Yield>4</Yield>
    		</Row>
    		<Row>
    			<SpecialistType>SPECIALIST_PURITY</SpecialistType>
    			<YieldType>YIELD_CAPITAL</YieldType>
    			<Yield>2</Yield>
    		</Row>
    	</SpecialistYields>
    
    	<BuildingClasses>
    		<Row>
    			<Type>BUILDINGCLASS_OLD_EARTH_WORKSHOP</Type>
    			<DefaultBuilding>BUILDING_OLD_EARTH_WORKSHOP</DefaultBuilding>
    			<Description>TXT_KEY_BUILDING_OLD_EARTH_WORKSHOP_DESC</Description>
    		</Row>
    	</BuildingClasses>
    	<Buildings>
    		<Row>
    			<Type>BUILDING_OLD_EARTH_WORKSHOP</Type>
    			<BuildingClass>BUILDINGCLASS_OLD_EARTH_WORKSHOP</BuildingClass>
    			<Help>TXT_KEY_BUILDING_OLD_EARTH_WORKSHOP_HELP</Help>
    			<Cost>-1</Cost>
    			<ConquestProbability>0</ConquestProbability>
    			<EnergyMaintenance>0</EnergyMaintenance>
    			<Description>TXT_KEY_BUILDING_OLD_EARTH_WORKSHOP_DESC</Description>
    			<Civilopedia>TXT_KEY_BUILDING_OLD_EARTH_WORKSHOP_PEDIA</Civilopedia>
    			<ArtDefineTag>ART_DEF_BUILDING_OLD_EARTH_WORKSHOP</ArtDefineTag>
    			<IconAtlas>BW_ATLAS_1</IconAtlas>
    			<PortraitIndex>14</PortraitIndex>
    			<SpecialistCount>1</SpecialistCount>
    			<SpecialistType>SPECIALIST_PURITY</SpecialistType>
    		</Row>
    	</Buildings>
    
    
     
  2. GenEngineer

    GenEngineer Prince

    Joined:
    Aug 24, 2014
    Messages:
    456
    First thing that springs to mind is that you're missing the TXT key for the Specialist itself - something like:

    <Language_en_US>
    <Row Tag="TXT_KEY_SPECIALIST_PURITY">
    <Text>Purity|Purities</Text>
    <Plurality>1|2</Plurality>
    </Row>
    </Language_en_US>

    Might help the game to define it on the building better and keep it from freezing up on that screen. Also, I seem to remember having trouble when trying to get a new specialist of my own to call Capital as a yield - the game considers it as such, but specialists don't seem to want to work with it. If it still doesn't work after adding the text, try commenting out the Capital part and see if that fixes it.
     
  3. Starrynite120

    Starrynite120 Prince

    Joined:
    Jul 15, 2015
    Messages:
    472
    I figured out the problem, I activated the files in the wrong order so the building was trying to reference a file that hadn't been activated yet. Thanks for the tip though.
     

Share This Page