Altered goodies not appearing?


Jan 9, 2006
Hey guys, basically what I'm trying to do is very simple:

I'm trying to make every tribal village on any difficulty only give you a gunship.

I've created the GameInfo folder in my mod folder, and have an altered CIV4GoodyInfo and CIV4HandicapInfo XML file within it.

Could someone PLEASE point out what's incorrect in these files? Thanks!

<?xml version="1.0"?>
<!-- edited with XMLSPY v2004 rel. 2 U ( by Jesse Smith (Firaxis Games) -->
<!-- Sid Meier's Civilization 4 -->
<!-- Copyright Firaxis Games 2005 -->
<!-- -->
<!-- Goody Infos -->
<Civ4GoodyInfo xmlns="x-schema:CIV4GameInfoSchema.xml">

CIV4HandicapInfo attached to post below:


    2.7 KB · Views: 61
Just a wild guess, maybe the number of <GoodyType> tags matters. It's 20 for all difficulties unmodded.
Tried that, still the same thing happens: whenever a unit goes into a tribal village it makes the correct sound, the correct animation but no unit is given!
Ok next guess then. You need to be able to build the unit and you don't have the tech to do so.
Top Bottom