BTS Graphics Problem

desvergeh

Chieftain
Joined
Sep 18, 2007
Messages
4
Hi Everyone,

Not sure if anyone else if having a similar problem, but I cannot get BTS to work properly on my computer.

I have both Civ4 and Warlords installed, and these work absolutely fine. But when I attempt to run BTS I get messed up graphics.

If I navigate into options, and turn off the anti-aliasing, this fixes the graphical problem temporarily. But then after a few turns the problem re-occurs and no tweaking fixes it.

I'm not sure if it is of relevance, but if I load Warlords or Civ4 after the BTS problem, the graphics are screwed up in those too. I need to restart my computer in order to fix the problem then.


I will update this post when I get home, including a screenshot of the problem and the directX read-out.

If anyone has any ideas on how to fix this it would be great. So far I have tried re-installing BTS, downloaded the latest patches and upgraded to the latest video card drivers.
 
Attaching an image of the graphical weirdness I am having and the DxDiag file.

I am running civ version 303, with build version 3.0.0.91(74697).

Any suggestions would be much appreciated.


broken graphics2.jpg

View attachment DxDiag.txt
 
3.03 version is so bad .. I Propose you return to the standard version (3.00) ..

You Have Geforce 5600 - Try install drivers ForceWare 94.24 WHQL (or 93.71) but latest drivers 162/163x is very faultly for GeForce Series 5,6,7

Tried both driver sets, and re-installing BTS to get back to version 3.00. Made no difference :(

Any more suggestions? Tried pretty much everything I can think of besides buying a new video card.
 
Managed to get it fixed. Actually found the answer in this thread -

http://forums.civfanatics.com/showthread.php?t=232577&page=3

The problem this thread relates to isn't exactly the same as I was experiencing, but was similar, so I thought it worth a shot.

Basically just installed -

http://www.dll-files.com/dllindex/dll-files.shtml?d3dx9_32

http://www.dll-files.com/dllindex/dll-files.shtml?d3dx9_31

Into my civ4 folder, and it now works. Still not sure what exactly the problem was, but it now works, so I'm happy.

Thanks for the help guys.
 
Top Bottom