1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

[BXP] BAT Xtras Packs - Modpacks for BAT 3.0 and above

Discussion in 'Civ4 - BTS Unaltered Gameplay (BUG, BAT and BULL)' started by Lemon Merchant, Oct 29, 2010.

  1. Dragon32

    Dragon32 Chieftain

    Joined:
    May 30, 2016
    Messages:
    2
    Hi.

    Just registered so it's a shame my first post is a "this doesn't work right" one. Apologies :sad:

    I managed to pick up Civ IV and its two expansions second hand last year. I looked around for some graphical enhancement mods and that led me to BAT and ultimately Better BAT AI 2.1

    Really enjoyed playing with it, not just the graphical enhancements but the UI is so much better.

    Anyway, I saw the Civ 6 announcement and got an urge to play with BAT again. I saw these Xtras Packs and thought I'd try them out. I downloaded the latest versions on the 25th but when I try and install them I get an error:

    I've only attempted to install "BXP LeaderHead Pack 2.0.exe" and "BXP MEE 1.0.exe" so far, I wasn't sure if installing MEE after one of the new civilisation packs would cause an issue.

    The BAT Mod itself runs fine (just played a game where I lost, again, I'm not the best at this... :) ).

    Shortcut is:
    "E:\Sid Meier's Civilization 4\Beyond the Sword\Civ4BeyondSword.exe" mod="Better BAT AI"

    I assume that I can run these Xtras Packs with Better BAT AI and so there's an issue with the installer? Or am I wrong and there's some fundamental difference between BAT 4.1 discrete and the version of BAT in Better BAT AI?

    Thanks for what is obviously a huge amount of effort that has gone into BUG, BAT and its constituent parts.
     
  2. Lemon Merchant

    Lemon Merchant Professional Killjoy Moderator

    Joined:
    Jun 27, 2008
    Messages:
    7,230
    Gender:
    Female
    Location:
    Red Sector A
    Hmm. Not sure what is causing this. I'm looking into it. Stay tuned.
     
  3. Lemon Merchant

    Lemon Merchant Professional Killjoy Moderator

    Joined:
    Jun 27, 2008
    Messages:
    7,230
    Gender:
    Female
    Location:
    Red Sector A
    I have a couple of questions for you to help me figure this out:

    1. Is this a Steam installed copy of Civ4?
    2. Are you trying to install these packs with Better BAT AI? If so, the installer won't work.
    3. Is BAT 4.1 properly installed?
    4. Have you tried running the installers as Administrator (Right click and choose "Run as Administrator")?

    As to your questions:

    1. The version of BAT that is in Better BAT AI is fundamentally the same as what is in BAT 4.1.
    2. The BXP packs will work with Better BAT AI, but will not install to Better BAT AI at the present time. I have not written installers for BBATAI yet.
    3. MEE should be installed first, before any of the packs.

    Sorry for the long wait in replying. RL had been a bear lately. :(
     
  4. Dragon32

    Dragon32 Chieftain

    Joined:
    May 30, 2016
    Messages:
    2
    1 - Disk install (I picked the disks for Civ IV and both expansions up second hand for about £10. Stunning).
    2 - Yes I am. That'll be where the problem is then.
    3 - As above, only Better BAT AI installed.
    4 - No I didn't try that, but it seems a little academic based on the above :)

    Well I hope RL turns into a cuddly teddy for you soon. No worries on this reply taking a few days, I appreciate the response.

    I'll keep an eye on this thread for a Better BAT AI-compatible installer, but don't feel any obligation to do that. RL sadly takes precedence, although sometimes we all wished it didn't.
     
  5. godborg

    godborg Chieftain

    Joined:
    Jan 20, 2011
    Messages:
    13
    Hello Lemon Merchant ! Will there be a fix for the leaderhead pack and the other bxp mods for the german version. There is no need for a translation, just a fix. The problem is : The Leadernames and civilizations are not shown in the list correctly. So you cannot see which leader/civ you are chosing in the gamemenu.

    Someone has fixed it for Bat Mod 3.* with BXP. I uploaded the file. Maybe it'll help for a fix for the 4.1 version.

    Edit: Someone = Sir Pustekuchen

    https://forums.civfanatics.com/thre...bat-3-0-and-above.395437/page-4#post-10151468

    /Edit

    Thanks for all

    Edit: I find out, that Lech Walesa from the poland pack and Macha Mong Ruad from the ceilidh pack are shown correctly - but their civilizationnames not. I wasn't able to transfer the needed changes in the matching _CIV4GameText.xml . Someone here who is able to do it?
     

    Attached Files:

    Last edited: Sep 18, 2017
  6. Lemon Merchant

    Lemon Merchant Professional Killjoy Moderator

    Joined:
    Jun 27, 2008
    Messages:
    7,230
    Gender:
    Female
    Location:
    Red Sector A
    Thank you godborg. I really appreciate it when someone steps up and offers help with other languages, because it's something that I can't do. Thank you for the files. I'll incorporate them soon. And I'll fix the problems in the Poland and Ceilidh pack. Were the others ok? Or have you tried them?
     
  7. godborg

    godborg Chieftain

    Joined:
    Jan 20, 2011
    Messages:
    13
    Good morning !

    Thanks for your fast response. I added some screenshots to show you the concrete problem. In the first picture you see Lech Walesa is shown correctly in the menu. The others above and behind not. This are the leaders in the leaderhead pack. In the second picture the nation behind Lech Walesa is missing. Same problem on the other civs. The 3rd and 4th picture show the problems in the civiliopedia. Names and descriptions of the leaders are missing there too. Lech walesa is shown correct. I started the game as Lech and you can see, that the name of the nation isn't shown int the list at the bottom right corner. Instead you see txt_key_civ_poland_desc.

    Same problems with the other addon packs.

    I hope this will help a bit !

    Thanks for your great work. My friend and i like to play civ 4 with your mods more than the buggy (multiplayer) civ 5.

    If you need a tester for the files, i am here.

    Edit : I found the post from Sir Pustekuchen. He has fixed the files a few years ago for the 3.* version.

    https://forums.civfanatics.com/thre...bat-3-0-and-above.395437/page-4#post-10151468
     

    Attached Files:

    Last edited: Sep 18, 2017
  8. godborg

    godborg Chieftain

    Joined:
    Jan 20, 2011
    Messages:
    13
    Hello Lemon Merchant ! Was it helpful ?
     
  9. Lemon Merchant

    Lemon Merchant Professional Killjoy Moderator

    Joined:
    Jun 27, 2008
    Messages:
    7,230
    Gender:
    Female
    Location:
    Red Sector A
    Yes it was. Thank you godborg. I'm sorry it took so long to reply.
     
  10. godborg

    godborg Chieftain

    Joined:
    Jan 20, 2011
    Messages:
    13
    @Lemon Merchant

    Happy new Year !

    Did you found a solution for the problem?

    I do not want to press you.

    Greetings
     
  11. Errants

    Errants Chieftain

    Joined:
    Jul 24, 2013
    Messages:
    5
    Necroing this, as it pertains to my attempted installations...:

    1. Yes.
    2. No.
    3. Yes, it'll run, have it installed via Varietas Delectat, to the appropriate folder in steamapps.
    4. Yes, same error as the OP you were responding to. Can't find 3.0...

    Thank you in advance for any help. It isn't game breaking, as I don't *need* those civs, but it would be cool to see what's been done.
     
  12. Lemon Merchant

    Lemon Merchant Professional Killjoy Moderator

    Joined:
    Jun 27, 2008
    Messages:
    7,230
    Gender:
    Female
    Location:
    Red Sector A
    Sorry for the late reply. The extra Civ packs will not install on a Steam based installation as the installer can't detect a Steam install. (I don't have Steam and therefore couldn't write an installer for Steam installations). What you can do, is use 7-Zip to unpack the installer and copy all of the files to the My Documents\Beyond the Sword\Mods\BAT Mod 4.1\assets\Modules folder, or wherever you have the BAT Mod installed.

    Find the Assets\modules\folders in the extracted files and copy everything in \modules to your BAT Mod Modules folder. Don't copy the rest of the junk. If you are installing Italy the files would be Assets\Modules\Italy <-- copy only Italy

    I believe that will work, but back up your BAT installation before you do it.
     
    Last edited: Jan 27, 2019
  13. Darkling

    Darkling Chieftain

    Joined:
    Apr 3, 2010
    Messages:
    24
    Hi, so I'm just reinstalling the extras pack and got an error message when the game was starting up.
    Tag ATTITUDE_FURIOUS in Info class was incorrect.
    I'd installed the scandinavia extra pack and it looks like there's an extra space on line 64 of Kekkonen_CIV4LeaderHeadInfos after ATTITUDE_FURIOUS.
    Code:
    <DemandTributeAttitudeThreshold>ATTITUDE_FURIOUS </DemandTributeAttitudeThreshold>
    I should add this is for the 4.1 version of BAT.
     

Share This Page