1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

[NFP] Civ will not launch after the update

Discussion in 'Civ6 - Technical Support' started by BomberEscort, Jun 25, 2020.

  1. BomberEscort

    BomberEscort Don't be alarmed; this is a kindness Supporter

    Joined:
    Jul 28, 2003
    Messages:
    1,125
    Gender:
    Male
    Location:
    Kansas City
    Civ 6 will not launch after the June 25th update. I have verified all files and disabled mods all except the official DLC. Is anyone else experiencing this issue? Even starting a game with standard rules only will crash.
     
  2. Flaxitux

    Flaxitux Chieftain

    Joined:
    Oct 24, 2016
    Messages:
    12
    Gender:
    Male
    Location:
    Suisse
    Testing after work
     
  3. BomberEscort

    BomberEscort Don't be alarmed; this is a kindness Supporter

    Joined:
    Jul 28, 2003
    Messages:
    1,125
    Gender:
    Male
    Location:
    Kansas City
    Not sure what the issue was but I had to uninstall, delete all the related folders and files and reinstall... now it works.
     
  4. Revanchist

    Revanchist Warlord

    Joined:
    Jun 10, 2020
    Messages:
    229
    Gender:
    Male
    Same issue
     
  5. Katyria

    Katyria Chieftain

    Joined:
    Jun 21, 2020
    Messages:
    6
    I downloaded the update when it came out and played for a while. My power went out and when I launched the game when it came back on, it detected launchpad.exe as a virus and removed it from my pc. So I validated the files on steam and tried to start the game but now it won't start. Going to try a reinstall as suggested!

    Edit: Reinstalling didn't work, it gets stuck in a verification loop.
     
    Last edited: Jun 25, 2020
  6. Flaxitux

    Flaxitux Chieftain

    Joined:
    Oct 24, 2016
    Messages:
    12
    Gender:
    Male
    Location:
    Suisse
    Happy it works - I got no issues still testing (playing)
     
  7. BomberEscort

    BomberEscort Don't be alarmed; this is a kindness Supporter

    Joined:
    Jul 28, 2003
    Messages:
    1,125
    Gender:
    Male
    Location:
    Kansas City
    Make sure you delete the Civ 6 folders and remaining files as well. I didn't do this the first time and the reinstall didn't work (nor did the verification I tried first). I then uninstalled (again), deleted the folders and reinstalled and it worked. I also unsubscribed from all community mods before I reinstalled.

    I think there is a problem with the files left behind in the LaunchPad folder.
     
  8. _Feniks_

    _Feniks_ Chieftain

    Joined:
    Jun 29, 2020
    Messages:
    5
    Gender:
    Male
    I had same issue - followed instructions from:
    Firaxis: You're only making this game worse
    and it worked for me - however cleaning registry is very time consuming as game doesn't clean up to good on it's own after uninstall.
    Now game seems to be working again - haven't tested any mods though...
     

Share This Page