1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

double production bug

Discussion in 'Civ2 - General Discussions' started by Major Advantage, Jan 12, 2012.

  1. Major Advantage

    Major Advantage Chieftain

    Joined:
    Mar 21, 2011
    Messages:
    463
    Location:
    Germany
    In the current GOTM I came across a bug/glitch that I couldn't find any info about:
    After completing my turn by hitting ENTER, my cities are processed for a second time! The year is frozen, the AI are frozen, but all of my cities have another turn of prducing shields, gold and science. I can only move those units that have been produced during that "ghost"-turn or units that have partial movement points left from the regular turn.

    Has anybody seen something like that?
     
  2. Ali Ardavan

    Ali Ardavan Mathematician Moderator Civ2 GOTM Staff

    Joined:
    May 29, 2002
    Messages:
    2,870
    Location:
    Michigan, USA
    Yes. I have seen this happen on occasion. I cannot explain why it happens, but it is exactly as you described. Sometimes if you reload the problem goes away.
     
  3. Major Advantage

    Major Advantage Chieftain

    Joined:
    Mar 21, 2011
    Messages:
    463
    Location:
    Germany
    Reloading helped, it didn't occur again. It took me some more reloads to reproduce exactly the same 2 hut-results I got at first try.
     

Share This Page