1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Failed to join the requested game

Discussion in 'CivRev - Multiplayer' started by clemenslinders, Jul 30, 2010.

  1. clemenslinders

    clemenslinders Chieftain

    Joined:
    Jul 30, 2010
    Messages:
    2
    LS,

    My children really like to play Civilization revolution on their PS3.

    Yesterday we purchased a new PS3 and a new Civilization Revolution game.

    I connected both PS3's wireless to my wireless Vigor router. Both PS3's started installing the latest PS3 firmware.

    Than I inserted the game. On both PS3's it started downloading version 1.30 of the game.

    On the older PS3 with 80Gb I started a new head to head multiplayer game. (PS I tried all other options as well).

    On the new PS3 with 120Gb I choose Multi player, Lan Party, Select game (I did find the game of the other PS3). But when I select this game I get the error: Failed to join the requested game! Please try again.

    I tried changing the PS3's so started it up on the new PS3 and tried to join from the other PS3. This gave the same result.

    On the internet I find that more people get this error, but I cannot find a solution anywhere.

    Currently I do not have a cross cable, would that be better?? If so can I use the cross-cable and have it connected to my wireless router, or should I in that case not use the wireless connection.

    I hope you can give me a hint as how to make this work wireless, that would be best.

    If I need to open a port on my router that is fine, but which port??



    Kind regards,




    Clemens Linders
     
  2. elthrasher

    elthrasher Revcaster

    Joined:
    Sep 11, 2009
    Messages:
    712
    I don't have one ps3, let alone two, but it seems to me that if both consoles are connected to the Internet, you can just have one start a private match and invite the other (by account name). On the xbox menus it would be Multiplayer->Player Match->Create Private Match. Then go to friends list and invite. I expect it's a little different on ps3, but probably something like that would work.
     
  3. Memento2

    Memento2 Chieftain

    Joined:
    May 10, 2011
    Messages:
    1
    Here are steps to get this working. Perhaps obvious to most people, but this note may be a bit of assitance for any other dummies like me. Also while not a point-by-point reply to the person starting this thread, it may help.

    My config:
    two PS3's, each System 3.60
    Civ Rev's v1.30
    and rather incidentally, a D-Link Dir-655 router/ wi-fi access.

    General LAN communication
    -------------------------

    First one hopes that machines all on the one-LAN side of one router don't have to bother much with the router's configuration, to communicate only with each other. Such as port forwarding and other security measures, which happen at the Wan-LAN transition point. That is mostly true with my D-Link, except two related exceptions.

    There are D-Link security options for "partitioning", which can keep LAN machines from talking to each other at all, when they never need to do so legitimately. The first option is between all wireless LAN machines, and the second between "guest" and normal "zones" of the LAN. Of course the general option has to be turned off for wireless LAN play. And if one PS3 is in your normal zone, and one in a Guest zone, then of course that Guest-zone partioning has to be turned off as well.

    [Such options are useful against a possible wi-fi intruder. Possible intruders are one argument for also running a firewall program on each LAN PC. However by using the strongest available router wifi-connection security, on each zone, the possibility of an intruder is greatly reduced. Separate topic.]

    If one CivRev can setup a LAN game, and the other CivRev can see that game, then the machines are talking fine. I have not tested with voice communication, which may be a similar indicator.

    If not talking, it is worth testing a machine-to-machine wired connection to eliminate the wi-fi/router networking as the problem. In general I think is is a good investment to have a spare Ethernet hub available for such testing. That's just a simple dumb connecting box, between two+ Ethernet cables, which does no "routing"/ checking/ filtering at all. And a cable long enough to reach between the furthest two machines/router which may ever need to communicate. Or two cables each to reach half-way, to the hub. It is easy to reconfigure each PS3 between wired test networking, and normal wireless. You do not have to re-enter all the wireless info when switching (back) to that.

    [CivRev does a "broadcast" message to the LAN, to most ports in the range 26900 - 26996, to identify other CivRev machines on its LAN. If setting up your wifi connection does not need/use UPnP, it does not matter for CivRev itself whether the PS3's have UPnP enabled.]

    Within CivRev
    -------------

    Perhaps you may see a game and try to join it, but get "Join Error... Failed to join the requested game." Check whether the game host had picked their Civ and already selected "I'm Ready." This looks tempting to do, but better for the host to wait until enough people have joined and the joiners are each ready. As listed on the right side of the "Lan Play" screen, each with their green circle/ check mark.

    Interesting that more than one person can choose the same Civ! Cheers.

    Other key phrases:
    Civilization Revolution
    How to start LAN play
    How to play LAN games
     
  4. clemenslinders

    clemenslinders Chieftain

    Joined:
    Jul 30, 2010
    Messages:
    2
    We're three years further and I decided again to see if I could make it work.

    And after quite some efforts I finally got it to work.

    The game itself was updated to V1.30 (latest version).

    I tried Multiplayer/Lan Party on PS3 A I created a party and on PS3 B I tried to join.

    I ended up with exactly the same error. I tried wireless/Cabled didn't work. I tried a separate router, a straight cable from A to B. It all resulted in the same error (failed to join the requested game).

    I tried all the other options besides Lan Party and all mentioned I wasn't connected to the Playstation Network.

    So I created a user for the Playstation Network, for each Playstation a different user.

    Again I tried connecting (setup a Lan party on A and connect on B) through a Lan Party and now I got something different. It now mentioned something like trying to connect to game. Wheels were turning, but after 5 minutes nothing changed. It still said Trying to connect.....

    Than I came across my own post and saw Momento2 posted an answer. And I must say now it works.

    I don't know if adding this Playstation Network account on both systems was neccessary or not, it appeared to be one step closer.

    But when you choose a Lan Party and create a Lan Party on Playstation A, than do NOT press the X / I am Ready. Than the game will start on Playstation A and Playstation B can no longer join (although at the side from B this is not mentioned or whatever).

    On Playstation A you must create a Lan Party game and do NOTHING. Than on Playstation B you must enter the Lan Party game. On the playstaion B you will see that Playstation A is the top player, and below is the player for Playstation B (PS the names of the Playstation Network are used, so this may be an indication, that it is mandatory to have these playstation Network account, the account itself is free by the way).

    So Playsttation B joined the game. Playstation A will now see that Playstation B joined the game. And NOW playstation A can press the X / I'm ready.

    Finally it works!!!!

    I must say that the way this has to be setup without any form of help on the screen or whatever is very very very poor.

    I think I read that FireAxis sold more than 1 million copies of this game (times an everage of 40 euro's!!!), than one might expect that this would be better handled.

    The game itself is great, we're hoping that a new version will come out at some point.

    Anyhow I hope that others read this post and get it working with less effort than me.
     
  5. UIUC_No1

    UIUC_No1 Chieftain

    Joined:
    Jan 15, 2015
    Messages:
    1
    Joined the forum with the sole purpose of saying thank you to Clemenslinders and Memento2. I had been trying nearly everything under the sun to get a LAN game set up so that my family and I could play on the PS3's we have.

    It really is amazingly simple, all you have to do is not hitting the 'ready for game' button until everyone has joined. (Assuming the other PS3's can 'see' one another)

    Thank you again and happy gaming.

    Best,
    C.H.
     
  6. GilHicks

    GilHicks Chieftain

    Joined:
    Apr 5, 2016
    Messages:
    1
    Hey everyone,
    I'm currently having getting a similar error when trying to play with friends over Xbox live on the 360. I can join and start a game if it's hosted by someone else, but if me and my friend try to join the same game or join a private game I start we get the "failed to connect, please try again error" .
    I wasn't sure the Xbox live servers for civ rev were still up but I see some active games (very few, obvious) and can connect to them, I'm just baffled by why I can't connect with my friend in a private game.
    Any suggestions would be greatly appreciated.

    Gil
     

Share This Page