1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Game crash/view issues

Discussion in 'Community Patch Project' started by Fiveminutes, Feb 20, 2020.

  1. Fiveminutes

    Fiveminutes Chieftain

    Joined:
    Jan 20, 2016
    Messages:
    5
    Hi,

    I've decided to see what changed after a year or so, however I've encountered few difficulties.

    First of all, VP worked for me long time ago, I played it way before new launcher.
    I downloaded latest version, went throught auto-installer, changed language to english on Steam, and here we go:

    First run - directx 9 - game launched with screenshot attached and few more, all regarding .dds file. On very top of screen (yields) I could see like science=unknown, happiness=00000000 and so on.
    Tried dx11 - game didn't load at all. Started it, but it got stuck at loading screen (character bio), so i reinstalled VP - same story.

    I started disabling all the mods to find out the one that causes the crashes - it is Community Balance Overhaul.
    I clicked it and there's a hint to remove LUA folder so I cut it to different path. It worked.

    However whole view looks very different than I remember. Starting on map screen: I remember that next to yields icons on top you could see turns remaining e.g. get new tech/new GP.
    In city screen it also looks different, there is a button 'purchase gold/faith', I remember you could see gold missing (in red color) for a buy.
    When I selected units all orders buttons (fortify,move, build etc.) are on far left, I recall they were horizontal above unit picture.

    Now it's been a long time since I played VP, I'm not sure if I remember correctly, thing were changed, mod is not loaded.

    Could somebody clarify if view things were changed or it is just my memory. Also could somebody assist if getting old view is possible?

    Regards,
    Five.

    PS. I would like to attach an ingame screenshot, however they are all black.
    PS2. I started game the game on king and I had 50 happiness already, is this intended?
     

    Attached Files:

  2. HeroOfTheSword

    HeroOfTheSword Chieftain

    Joined:
    Jun 16, 2016
    Messages:
    6
    Gender:
    Male
    Location:
    Dublin
  3. kenneth1221

    kenneth1221 Warlord

    Joined:
    Apr 18, 2016
    Messages:
    203
    Make bug reports on the github, it's meant to track bugs.
     
  4. Tugboatspotter

    Tugboatspotter Warlord

    Joined:
    Dec 19, 2019
    Messages:
    201
    Default VP installs EUI.

    Is this what is different? You can choose to install VP without EUI if you prefer.

    Delete mods, cache and mod data from civ v docs, and then go to civ v assets/dlc in steamapps and delete UI_bc1

    Reinstall VP without EUI and maybe it is as you remember?
     
    Last edited: Feb 21, 2020
  5. vyyt

    vyyt Deity

    Joined:
    Jan 28, 2005
    Messages:
    2,210
    Location:
    Czech Republic
    Yep, this is typically happening when EUI lands in a wrong location. Check my post #3059 in the install thread for troubleshooting (you need to move EUI from the wrong = default folder to the correct = non-standard location).
     
  6. Fiveminutes

    Fiveminutes Chieftain

    Joined:
    Jan 20, 2016
    Messages:
    5
    Resolved by moving files. Thanks!!

    As this is a known issue, could somebody delete/lock thread?
    Sorry for bothering you guys.
     
    vyyt likes this.

Share This Page