Help! Crash Problems with Edited Civilizations!


Designer, Mohawk Games
Dec 20, 2001
Pennsylvania, USA
OK, so I tried my hand at making a map and one custom civ, and I've gotten that working. (Thanks Dan). This success has whet my appetite and I'm interested in designing a full blown mod. I have plenty of ideas of how to make it fun and balanced, and what I want it to play and feel like. So I started working on it with the new editor in the new patch.

I started by renaming all the civs, changing some of the colors around, changing some of their "what to build often" priorities, and their inherent civ traits (I kept two apiece, and kept at least one of each pair combo -- like religious, scientific).

Result? The game crashes immediately on trying to start. :(

So I figured a little trial and error, I probably did one or two things wrong, or tripped over a bug. I started over completely from scratch and altered just a few things about a few civs, such as the civ names, inherent traits. No colors yet, no priorities. This seemed to run OK, so I worked from there, changing a few more things, then a few more. Some color changes, and it still worked OK, but then all of a sudden it didn't any more. It was crashing on the second turn. (Not the first turn, as originally). Yet I wasn't doing anything differently than what I did in the parts that weren't crashing.

So I backed up to the previous "last working version" of the fledgling mod and tried again. Now I'm getting a strange error where the game locks up if I let the settler wait, and move the worker or scout first. After that, I can't get it to found the first city.

I've tried several times to isolate WHAT in the editor is causing the problems, but I haven't been able to pin it down. I don't even know what is causing the crashes, and get the sense that the problems are beyond what I can address with patience alone. The kinds of changes I'm doing are simple, and right there as options in the editor with no warnings about "this feature isn't operational yet, don't use it", or that sort of thing. The editor itself is VERY stable, but the edited results it churns out are apparently still raw and unstable, and increasingly frustrating.

The editor needs to do whatever is necessary to make the results functional. Having to go out and manually do this, that, or the other, to keep the game from crashing, would be acceptable (for the moment) if I knew what to do, but the Editor help file is a typical windows help file that presumes the editor itself does what it claims, and at this point that's not the case.

And here I thought I would run into troubles when I tried to alter the whole tech tree, create new units and resources, and such more drastic things. But I am stuck on the very first step of customizing the civilizations, as even doing some of that has got me stumped now. I'm trying to make a mod to increase my fun. Having an editor that dangles options in front of me, which then are not functional, is almost a kind of torture. :)

In case it wil make a difference, I am attaching a zip with four examples. v0.01 was my original attempt to start on this mod, with all the altered civs. It crashes hopeless at startup every time. v0.05 is the farthest into modifications I've gotten without having crash problems, and temp1 and temp2 are subsequent attempts to add more changes to 0.05, that have failed, and are leading to different crash results and problems. So that's one working example, and three failed examples each with different symptoms. (I feel like I am making a beta report here, heh).

If anybody has an advice list of "Do's and Don'ts" regarding how to prevent instability and come out with a usable mod result from the editor, I'm all ears. The last crash I had, I was able to pinpoint the direct problem and get a swift answer from Mr. Magaha, but here I don't even know what's going wrong, and cringe at the thought of possibly dozens of such issues rising with each new thing I attempt to customize. ... Help? :confused:

- Sirian
I'll try to take a look tomorrow and see what's going on, in the meantime, a couple of areas that almost always cause problems are team colors and barbarian tribe names. If you've messed with either of these, it could be the source of the problem...

It is the color problem.

Unzip this file into Art\units\Palettes and you will be able to use all colors.


    3.2 KB · Views: 111
Thanks, Gramphos. I presume I'll have to include this color patch with my mod, along with any other added/altered files (like unit folders) for the mod to function for others. If/when I run into any further troubles, I'll be back with more questions. :)

Thanks, Dan. Yes, I did mess with barbarian names, too, at one point. That may be the hard crash from my mod v0.01 that doesn't even let me into the game? I got that "must enter 76 lines" error message in the editor that locked me up for a bit, I ended up opening a second editor session, copying the original Barbarian list and pasting that into the file I was working on, to prevent losing all my work from the last time I had saved. If the Barb names and team colors are a known issue, then probably nothing new in my examples. Would there happen to be a list of "known issues" lying around anywhere? If not, compiling and posting one might save editor users some hassles, and save you guys who are trying to be helpful from having to repeat answers. Thanks again for the help.

- Sirian
Top Bottom