1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Init Engine Error (Invalid 3D device type)

Discussion in 'Civ4 - Technical Support' started by GB123, Jul 10, 2010.

  1. GB123

    GB123 Chieftain

    Jul 10, 2010
    Purchased CIV 4 (Game of the Year edition) and I am having problems with the install/startup of the game. I am running Windows 7 (32 bit) edition. The post below are the details of the system and the error message (appears related to DirectX)

    DirectX diagnostic Tool:
    System Information:
    Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7600)
    System Manufacture: HP Pavilion 061
    System Model: DN124A-ABA 869C
    BIOS: BIOS Date: 06/27/03 20:48:32 Ver: 08.00.08
    Processor: Intel(R) Pentium(R) 4 CPU 3.00 GHz (2 CPUs), ~3.0GHz
    Memory: 2048MB RAM
    Page file: 996MB used, 3098MB available
    DirectX Version: DirectX 11

    Name: Standard VGA Graphics Adapter
    Manufacture: (Standard display types)
    Chip Type: NVIDIA
    DAC Type: 8 bit
    Approx. Total Memory: n/a
    Current Display Mode: 1280 x 1024 (32 bit) (1Hz)
    Monitor: GenericPnP Monitor

    ... All DirectX features show "Not Available"

    The error occurs
    at the last stage of the InitEngine with the followling:

    Initialize Renderer failed. Check DirectX Installation, Latest Graphics
    Drivers and Graphics Settings
    - width = 1024
    - height = 768
    - flags = 0xc
    - hwnd = 0x470664
    - adaptrid = 0
    -deviceid = 3
    Error:Creation failed: Invalid 3D device type

    I have checked serveral threads in this and a few other forums but nothing indicates that it works (or doesn't) in Windows 7.

    BTW - This is a new install on this machine. Used to run CIV II but de-installed it
    prior to atempting to install CIV 4.

    Any assistance would be greately appreciated.

  2. Furiey

    Furiey No Longer Just Lurking

    Nov 18, 2003
    Bedfordshire UK
    Welcome to CFC! :band:

    It does work on W7.

    Install the most recent version of DirectX 9c from Microsoft

    Make sure you have the latest patches installed, Warlords should be 2.13 and Beyond the Sword 3.19 (I'm not sure from memory what expansions game of the year includes). You can download these if you need them from the downloads section of this site.

    Make sure you run any patches by rightclicking on the .exe and selecting run as administrator.
  3. nordicwolf

    nordicwolf Chieftain

    Aug 18, 2011
    I have the same problem. Same error. I followed this to the letter, http://forums.civfanatics.com/showthread.php?t=408537 even using the original disks and a digital download from amazon. Still get the same "3D" error.

    I read on other Forum posts that it runs on Windows 7, but I have no idea how.

    Furiey, can you help?

Share This Page