• Civilization 7 has been announced. For more info please check the forum here .

Installing BtS

Abusse

Chieftain
Joined
Jan 7, 2009
Messages
17
I recently uninstalled Beyond the Sword, successfully this time... and then I try to reinstall it... and it does so for about 10 seconds before the installation stops from a "Castrophic failure" error... what is happening?

I'd send a screenshot but I don't know how to attach thumbnails


Feature Transfer Error (in blue bar)
Feature: Default Feature
Component:
File:
Error: Catastrophic Failure
 
I hope the thumbnail appears...
 

Attachments

  • ERROR.JPG
    ERROR.JPG
    130 KB · Views: 72
during the installation, right after it searches for the ActiveX or directX parts or etc... it starts to install and then that error pops up, you can see that in the screenshot, 1 block done then ERROR
 
I was just asking this - since this can happen as a result of a dirty or damaged disc, in which case though it would also happen when you try to copy the contents of the disc to the hard drive...
please open the windows event manager and check for any error messages in there - maybe that includes some more information...
 
The disc seems fine, everything copied fine. I dont know what Im looking for in windows event manager. No mention of the word error comes up... it does however mention the setup installer starting and running, and then ending 9 or 10 mins later, but the error usually occurs almost immediately after it begins to run.
 
No, it never worked. I think the problem stems from the fact I put it on an external hard drive. So I'd advise anyone, don't put it on an external hard drive, because I got the usual uninstall error, so I taped down the ignore key until it said it was successfully uninstalled and simply deleted the program file. Then I posted here when I tried to reinstall it.

After the numerous failures I just restored the files before windows automatically deleted them....

But yeah... still cant do patch updates, game randomly closes when I use civlopedia, and can't load some mods (had all of these problems before the uninstall)

Any remedies? Because I can't properly uninstall the game, or install the game.
 
for just removing the game from the registry do the below - that should allow you to reinstall to a suitable location. If you want to really get rid of the game there are more keys littering the registry though...

IF deleting the installshield information files does not help
edit the registry manually:
search and delete these keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{CFBCE791-2D53-4FCE-B3FB-D6E01F4112E8} -> Civ4
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{3E4B349F-10B5-4586-9D99-489A90A8B228} -> Warlords
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{32E4F0D2-C135-475E-A841-1D59A0D22989} -> BtS

Note: use regedit with caution - and do set a system restore point before doing so. While this is the *right* way of getting rid of the game (I agree with Jeckel here) it is also dangerous
 
I have no idea what you're referring to by registry key (or where any of those files are for that matter), and why would I delete the registry key for Civ 4 and Warlords?
 
:)
sorry: you just need to do it for BtS I just quoted this because I had forgotten how the key is named exactly - so I used the first post I found where I had posted them :mischief::
if you open the registry with regedit you can just search for the keys or click through the tree - there you would first click on the + sign next to hkey_local_machine then on the plus sign next to software and so on until you find the one with this weird numbers and letters combination - or just use the search function to search for the whole key :)
 
No, I'm willing to do everything you're telling me, the problem is I dont know how to find the registry! I tried googling how to find it, and that was useless because its all about registry repair and cleaning. I don't know to find it. I am not tech savvy, IE why I'm here, I am completely clueless as to what this mystical registry does, and what its purpose is.
 
Top Bottom