1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. We have selected the winners of the Old World random draw and competition. For the winning entries, please check this thread.
    Dismiss Notice
  3. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

Mods not working

Discussion in 'Civ6 - Macintosh' started by Steve W, Jul 15, 2020.

  1. Steve W

    Steve W Chieftain

    Joined:
    Jul 15, 2020
    Messages:
    1
    Gender:
    Male
    Hi all,
    Ive read many of the threads here and have managed to locate the correct directory and correctly save mods to the directory. They appear in the mods menu at startup.

    Im running Civ 6 on my mac in OS 10.15.4

    The game runs really well in normal format.

    But for some reason I cannot get mods to run. I can see them on the menu, both downloaded and genuine content. When I click or double click on them they do not activate.

    Any tips for a total noob to mods?

    Thanks

    S
     
  2. borad

    borad Warlord

    Joined:
    Nov 14, 2008
    Messages:
    117
    Can you deactivate offical mods?

    Since NFP I can see all my mods, but I can’t turn any on and I can’t turn any DLC off.

    Un-installed and re-installed, no change.

    At least the previous bug where I appeared to have Khmer+Indonesia twice, and it still didn’t load, has gone away…
     

Share This Page