• Civilization 7 has been announced. For more info please check the forum here .

New game settings recommendations?

buck beach

Prince
Joined
Dec 2, 2001
Messages
494
Location
Upland, California
Frustrated with my current game and the constant MAF and/or Runtime crashes. Game is a giant world with graphics set to low resolutions and at 1280 x 1024. Thought my computer could handle it because I had no trouble with Caveman to Cosmos or ROM a new Dawn but apparently I am wrong. Here's my rig:

Operating system
Windows 10 Home 64-bit
Microprocessor
Intel(R) Core(TM) i7-9700 CPU @ 3.00GHz
System memory
16 GB
Memory slot 1
16GB Kingston 2666MHz

Graphic device 1
NVIDIA GeForce RTX 2060
Current resolution
3440 x 1440
Refresh rate
49 Hz
Version
27.21.14.6172 (2/23/2021)

So what will be the largest world my machine will handle.

Buck
 
The obvious recommendation is to try going smaller, one or two map sizes. It is hard to say exactly, but I had no real trouble on comparable config with huge maps, and large should definitely not cause any.
 
Before I go further I want to thank you and team for the many hours and years of fun I have had with this mod and all the work you have done. I realize that it is impossible to address everyone's issues especially with all the numerous different machines and configurations and the age of the base game.

Here is where I am now and it seems to been a different crash issue. Print screen attach shows the new game configuration (note size of world map reduced to just Large).

My game when tread started went to Jul 1897 and a Save Game size of 6967KB before I gave up with all the crashes and MAF/Runtime error messages. Obviously I was pushing everything beyond the max. This new game is now at Oct 1951 with the save game size of 2189KB and my crashes now go to black screen the desktop WITHOUT ANY ERROR MESSAGES when try to play on. I have tried going back several (5 or 6) turns and playing forward with different new build selections and no unit upgrades but I still get to a drop dead point of after October 1951.

I have a Oct 1951 save game, but really don't expect and won't be disappointed with no solution to this just another "Mission Impossible" issue. So THANK YOU again.
 

Attachments

  • Civ4ScreenShot0010.JPG
    Civ4ScreenShot0010.JPG
    152.3 KB · Views: 86
I think I fixed it for you, at least for the time being; didn't even have to delete anything substantial, just changed the production order in one of AI's cities. Hopefully that will let you continue.
 

Attachments

  • buckb AD-1951-October1.CivBeyondSwordSave
    2.1 MB · Views: 52
It was one of AI cities; I didn't understand why exactly that was causing a CTD (it was building a simple spy, same as several other cities), but after I switched its production to a different unit, everything worked.
 
Top Bottom