1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

No Internet option in Multiplayer

Discussion in 'Civ4 - Macintosh' started by ScullyTheWise, Jul 27, 2006.

  1. ScullyTheWise

    ScullyTheWise Chieftain

    Joined:
    Jul 27, 2006
    Messages:
    1
    So my friend and I were trying to start a Civ4 multiplayer game but ranin to a few snags

    1: Neither of us could connect using direct IP, I tried hosting, then he tried hosting

    2: we tried to move over to Internet game play but my multiplayer options didn't have it. I only have LAN, IP Connect, Hotset, and PBEM...

    can anyone tell me whats going on?
     
  2. Cougarcat

    Cougarcat Chieftain

    Joined:
    May 26, 2006
    Messages:
    117
    1. Check your firewall settings. Try turning it off.
    2. Civ IV doesn't have the Gamespy browser because the cost to license it is outrageous. If your friend has the mac version you can use GameRanger; otherwise, your only option is direct IP.
     
  3. ancestral

    ancestral Chieftain

    Joined:
    Nov 9, 2001
    Messages:
    181
    Location:
    Motion City
    You may have to go to your router by accessing it through an address like 192.168.0.1. Through my ActionTec router there was an option to disable the firewall and enable all traffic through and it said specifically works with gaming. Then to get my IP I go to the same page and access "status".

    I believe there is a thread in the forums just for dealing with routers. You may also try googling about this.
     
  4. Welnic

    Welnic Chieftain

    Joined:
    Jun 19, 2006
    Messages:
    1,057
    If you look up your IP number in the Network section of System Preferences that will show you your IP number on your LAN (local area network). That number probably starts with 192.168 and is just the IP number for your LAN traffic. To find the IP number that your router presents to the outside world you either have to log on to it as suggested above, or use a web utility that can tell you what your public IP address is. Try this link:

    http://www.dslreports.com/whois

    If you are on cable then I think that number rarely changes. If you have DSL that number will change whenever something restarts the connection. If that doesn't work then you might have to configure your router to direct the port that Civ4 uses to your specific machine. But I think that it should just work if you use the correct IP number.
     

Share This Page