1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Takes time to perform actions

Discussion in 'Civ3 - Technical Support' started by CivFan2k1, Nov 12, 2001.

  1. CivFan2k1

    CivFan2k1 Chieftain

    Joined:
    Sep 24, 2001
    Messages:
    19
    When I move a piece in the game it only moves after 2 seconds.
    Also it happens when I center the screen, scroll, enter a city etc.
    It's very annoying. Only someitmes it moves smoothly.
    When there's a unit that can move 2 squares, you move it one square it takes 2 seconds, you move it to another square, another 2 seconds, I'm not talking about the animation, but the game is like getting stuck or something for 2 seconds every time.
    what should I do?
    I have Pentium 4 1.4GHZ 256RDRAM, Geforce 2MB 32MB, I shouldn't have that problem.

    P.S. I think I didn't have it the first day, when I installed the game.

    Somebody, please help.
    Thanks.
     
  2. Dan Magaha FIRAXIS

    Dan Magaha FIRAXIS Firaxian

    Joined:
    Jan 12, 2001
    Messages:
    309
    Location:
    Hunt Valley MD
    Are you using the latest Detonator drivers? There are known problems with lag associated with Nvidia cards and the latest Detonators. Try installing the 12.xx drivers and see if it helps.


    Dan
     

Share This Page