1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Tested Mods using Wine

Discussion in 'Civ4 - Macintosh' started by z0wb13, Apr 6, 2013.

  1. z0wb13

    z0wb13 undead

    Joined:
    Feb 9, 2009
    Messages:
    657
    this is a companion guide for my how to on running windows versions of civ on osx using wine. some mods are compressed into rar files; you can use Keka to open them.


    Confirmed Working Mods:*
    * working means that i loaded each mod up and played until i met a neighbor (~10 turns) with nothing weird happening. some of these mods with AIAutoPlay enabled were tested for entire games. all the graphics, rules and menu changes appeared to work, without any crashing/reloading.

    2100
    American Mod Revolutions v1.1
    Ancient Astronauts
    AutoPlay319
    Babylon 5 V3.0
    Badgame 0.2 + BUG 4.4
    Barbarian (for BtS)
    BAT Mod 3.0
    Better BAT AI
    BlueMarble
    BUFFY-3.19.001
    BUGMod_4.4
    Caveman2Cosmos
    CivSuper Expanded
    Community Civ 5
    Dawn of the overlords
    DCM319 (Dale's Combat Mod)
    Evolution
    Extreme2
    Fall from Heaven 2
    Final Frontier Plus
    HISTORY IN THE MAKING
    K-Mod
    Legends of Revolution
    marsjetzt-v04 (Mars, NOW!)
    MaxRigaModBTS3
    Multiverse
    Neoteric World
    PieAncientEuropeV_Beta2 (Patch5)
    Planetfall v16
    Puppet States
    Quot Capita
    Realism Invictus
    RevolutionDCM
    Rhye's and Fall of Civilization
    RiseOfMankind2.9
    Rise of Mankind - A New Dawn
    Rise of Empires 3.5
    song of the moon 2
    Star Trek 4.31
    Stone Age Mod 2.90
    StrategicRivers
    TAM (The Ancient Mediterranean)
    TTT-Modern Alliances
    Unofficial 3.19 Patch
    Varietas Delectat
    VIP (Vincentz Infinite Projects v0.91)
    WWII in the Pacific

    not working (... YET!)

    BarbarianCiv
    FutureMod (crashes at launch)
    Grand Inquisitions 300 (freezes when initializing maps)
    Merged Mod 1.20 (loads and runs, but with graphical issues)
    RFRE.release1 (crashes at launch)
    Sevomod (freezes during launch with XML errors)
    Star Trek II: The Wrath of Mod (loads maps and plays, but game events aren't working right)
    The History of Three Kingdoms (plays fine after loading normal map, exiting to menu, then choose scenario)
    Thomas' War (crashes at launch, GFC error)
    TotalRealism-Setup-2.1 (installer cannot find civ4 path and fails to load)

    Important Notes:
    there are a few tweaks that need to be made in order for everything to run smoothly. if you followed my guide, everything should be good to go, but i thought that i would mention a few specifics


    note1: there is a button called Custom Executable Launcher Maker. it is found under Tools in the Wineskin Advanced window. you can use this to have autolaunch options for mods. choose a name, preferably something descriptive. browse to the correct exe file (so if you are using a mod for warlords or BtS, make sure you point to that version). then set an EXE flag to make your mod launch at start. when you click save you get a little .app file inside your wrapper. drag it out of the wrapper to run it from anywhere.



    note2: there are several ways to load mods: either by the in game menu, by editing the CivilizationIV.ini file, or by setting the EXE flag in wineskin advanced. the last choice is probably the easiest; make an alias to the Wineskin_Winery.app inside the civ4bts319 wrapper, and use it to set launch options.


    note3: make sure to UNCHECK map user mac osx folders in wrapper.

    note4: you must set msvcr71.dll to "native" in the Wine configuration menu.


    note5: i have run into some issues (missing tech trees, missing interface menus, etc.) if i load certain mods while using edited custom assets. you can find a fix for it here.


    Installing BAT:


    this mod uses an installer program or .exe file to load itself, which should make things easier. however, linux-like OS's, and this includes osx, are case-sensitive, while windows is not. make certain to check the installation path during setup and change it accordingly, as is the case with BAT.

    first, right-click on the civ4bts319.app and choose Show Package Contents, then double-click the Wineskin.app found inside. click Install Software and then Choose Setup Executable. navigate to Downloads and pick The BAT Mod v 3.0.1 Installer.exe. there are a few options to choose from, like un-clicking all of the shortcut files. i went ahead and chose to add the blue marble graphics and use it as a mod. also, make sure to change the install path to Bts\Mods (not Bts\MODS) to ensure that everything goes into the correct folder. when installation is complete, you will get an Oops message saying there wasn’t a new .exe file detected, which is OK.

    to load BAT, simply select it from the in-game menu.

    *

    *ignore this message.


    Installing BUG:
    there are 2 way to do this, as a mod or custom asset. as a mod, right-click on your civ3bts319.app and choose Show Package Contents. this will reveal Contents, drive_c and Wineskin.app. navigate to drive_c:/Program Files/.../Beyond the Sword/Mods and, once there, drag the BUG folder into position. to run it, launch civ4, then select it under Advanced options Load A Mod.



    so that’s the easy way, but let’s say you want to use it with succession or forum games. this is a little more complicated, here are the instructions:

    i found this a little bit confusing, so let me reword it.

    there are 2 folders named CustomAssets in your drive_c folder (not counting the one found inside the BUGMod itself). you will be using the one found under My Documents/.../Bts; make sure not to change anything in the Program Files/.../BtS/CustomAssets folder. first, unpack the BUGMod_X.X.zip folder. then create a folder named “BUG Mod” and copy GameSetUpCheck, Info and UserSettings inside. move this to the Beyond the Sword folder that is found under Documents (NOT Program Files, i cannot stress this enough). go back to the unpacked BUGMod, take everything from INSIDE the Assets folder, and drag it to the CustomAssets folder, then choose Replace All. finally, drag the files found inside PrivateMaps into the PublicMaps folder. not nearly as easy as running as a mod, but definitely worth the effort. just make sure that all of these files you are moving around didn't go into the Program Files.


    Installing All Other Mods:
    mods can either be installed into the MyDocs/.../MODS folder or the ProgFiles/.../Mods folder. this is a small but significant difference; some mods will crash to desktop if installed in the Docs/MODS folder, generally related to interface changes. so if you see a GFC error, try moving your mod into ProgFiles/.../BtS/Mods.


    screenshots of working mods:
    Spoiler :











     
  2. myfamilyguy76

    myfamilyguy76 Chieftain

    Joined:
    Sep 21, 2007
    Messages:
    69
    Does this work with Rhye's and Fall yet?
     
  3. z0wb13

    z0wb13 undead

    Joined:
    Feb 9, 2009
    Messages:
    657
    Spoiler :

     
  4. mudd1

    mudd1 Chieftain

    Joined:
    Jan 1, 2014
    Messages:
    4
    I originally posted the issue here but was then made aware of the fact that you already managed to install the Planetfall mod in Wine. However, it seems to have worked for you without any trouble.

    The problem I get is that the installer doesn't recognize the Mods directory as a valid installation path. It might be the case-sensitivity issue you ran into with other mods (although I find this odd either way; Linux and Unix and case sensitive but Wine usually isn't). However, I can't just tell the installer to install anyway and hope it will all turn out fine. Do you have any idea how to fix this or how to install the mod manually?
     
  5. z0wb13

    z0wb13 undead

    Joined:
    Feb 9, 2009
    Messages:
    657
    that's about right. i don't remember doing anything special to get that one to work. there are the 2 different mods folders, and the installer might be looking for the one or the other (?). sorry i can't offer any more help, it just sort of worked for me. all of the mods i list as working i played through a few turns, not extensively, but long enough to meet a neighbor and make sure things like the tech screen and advisers were working properly.

    also, i tested them on a mac osx, which uses the wine engine, but i didn't try it anywhere else. and i was using (and will continue to use, until there is some compelling reason to upgrade) the 1.4.1 version without X input.
     
  6. Xyth

    Xyth History Rewritten

    Joined:
    Jul 14, 2004
    Messages:
    4,054
    Location:
    Aotearoa
    I can confirm History Rewritten works with BTS via your wine setup. Of course it also works on regular Mac BTS, but I figured it was worth mentioning in case anyone wanted to know.
     
  7. drakaris

    drakaris Chieftain

    Joined:
    May 25, 2014
    Messages:
    1
    Hello!
    I've been using this wineskin wrapper and I really like it, and it works great with BUG mod. The problem is, that I also want to play Realism Invictus. It installs fine, but when I try to run it I just get an error message "error loading shader libraries". I am using a 2010 macbook with a geforce 320m and mavericks, and I just formatted it.
    Please help me :)
     
  8. Jeystone

    Jeystone Chieftain

    Joined:
    Aug 16, 2002
    Messages:
    43
    Location:
    Devon (UK)
    Can some one please explain how to get Caveman 2 Cosmos installed. Thanls
     
  9. Jeystone

    Jeystone Chieftain

    Joined:
    Aug 16, 2002
    Messages:
    43
    Location:
    Devon (UK)
    Hey @z0wb13 I see you have Caveman 2 cosmos running. Could you explain how that is done please. Thanks
     

Share This Page