1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Where to begin: Compatibility Issues (Windows 10)

Discussion in 'Civ4 - Technical Support' started by McMickeroo1, Nov 17, 2018.

  1. McMickeroo1

    McMickeroo1 Chieftain

    Joined:
    Jun 8, 2015
    Messages:
    9
    OK so basically I installed Civ IV, then BTS, and then immediately installed the 3.19 patch.

    There was absolutely nothing on my computer. No shortcuts. No programme. No folder for the games in programme files or anywhere else. No evidence at all that I'd installed the game. I clicked on uninstall a programme and all I could see was the civ iv programme installed, but it didn't have the Civ IV icon; it had the icon programmes have when there's nothing to load them on.

    Now at this point I fiddled around a lot and everything is pretty confused if I'm honest. I was able to uninstall Civ IV eventually, and then reinstall it, but there was little progress. I tried adding a patch specifically for Civ IV 1.74 I believe. The game does now appear and has a folder in programme files. However when I try to load it it says to turn on administrator privileges or something and then if I run it as administrator the programme just doesn't load up full stop.

    At this point it seems like I haven't uninstalled BTS and yet there is also no evidence that I've installed it.

    I may trying plugging in that disk again and report back. Until then could somebody please offer any comments?
     
  2. Fenryr

    Fenryr Chieftain

    Joined:
    Dec 2, 2018
    Messages:
    1
    I'm in the same situation, trying to install Civ 4 (complete edition) via DVD on Windows 10.

    Here's what I tried, which worked for me.
    • Open DVD
    • Right-click on the Setup.exe file, select Windows XP compatibility and admin execution
    • Launch Setup and wait for installation to proceed
    • During installation, I checked where the files shoud be copied (by default: C:\Program Files (x86)\2K Games\Firaxis Games\Sid Meier's Civilization 4 Complete). Everything seems to go well so far.
    • Open local files and apply compatibilty and admin execution on Civ4BeyondSword.exe, as well as on the Icon
    • Download and apply BTS 3.19 patch manually (.exe)
    I hope it helps.
     

Share This Page