1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

A couple issues running in Win10 (Patching and Game Responding)

Discussion in 'Civ2 - Technical Support' started by Sphynx87, Oct 15, 2019.

  1. Sphynx87

    Sphynx87 Chieftain

    Joined:
    Oct 25, 2016
    Messages:
    1
    Hey there, woke up and had the itch to play yesterday.

    Originally tried using my MGE CD along with FoxAhead's Editbox Patcher and the UI Additions. The patcher would run fine but the UI additions kept saying I didn't have 5.4.0f, so I tried using the official updater but it just doesn't work for me in Win10. I run it and it pops up for a second and then the process is just in my task manager taking up memory and no CPU, the installer just never runs. Bummer because the UI additions seemed useful but not the end of the world.

    Instead I used the method to upgrade the original 16 bit version of the game to MGE, got the Indeo video stuff working. Game works... for the most part. At the end of enemy turns when lots of enemies are visible the game window will stop responding and I can hear what is going on but I can't see it. Not the end of the world but it makes it harder to play. Saw a thread about it but no answers.

    tl:dr
    1) Is there a way to patch to 5.4.0f without using the installer?
    2) Is there a way to fix the window not responding at the end of turns?

    Thanks in advance.
     

Share This Page