1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Adding new Unit - Problems

Discussion in 'Civ3 - Creation & Customization' started by Houman, Aug 2, 2003.

  1. Houman

    Houman TR Team Leader

    Joined:
    Jan 24, 2002
    Messages:
    1,083
    Hi All,

    First of All I have already read all of the "How to" Threads. But I see all the time a knight instead of the Cataphract unit. I am trying since 3 hours...

    The Cataphract is here: http://forums.civfanatics.com/showthread.php?s=&threadid=22289&perpage=20&display=&pagenumber=11

    CIV3 : PTW 1.21f

    I have added a directory called \CIV3PTW\Scenarios\TETurkhan\Art\Units\Cataphract

    There is the INI file which is also named Cataphract.ini

    In the \CIV3PTW\Scenarios\TETurkhan\Text\PediaIcons.txt

    I have added the lines
    #ANIMNAME_PRTO_Cataphract
    Cataphract

    and

    #ICON_PRTO_Cataphract
    art\civilopedia\icons\units\15knightlarge.pcx
    art\civilopedia\icons\units\15knightsmall.pcx


    I have added with the Editor a new Unit which is also named exactly 'Cataphract', with the small Knight Icon and different values.

    In the game the Unit has the values as I have set before as a Cataphract, but it looks like a Knight. It can not load the Animation, why?? ( I load the Scenario of Tethurkan)

    Thank you
    Houman
     
  2. Colonel Kraken

    Colonel Kraken Chieftain

    Joined:
    Dec 27, 2001
    Messages:
    2,453
    Location:
    Grand Rapids, MI
    Hi Houman,

    I know these things can be frustrating. It sounds like you forgot to change the entry under "Civilopedia Entry" in the editor. It sounds like you currently have "PRTO_Knight" instead of "PRTO_Cataphract".

    So, you would have a new unit with different stats, but it would pull the old Knight animation instead of the new Cataphract animation.

    Hope this helps. :)

    --CK


    EDIT: Oops, I didn't realize you had another thread with the same exact question, but I'm glad my answer was correct. :)
     

Share This Page