Anyone know how to fix this graphics glitch in the worldbuilder?


Nov 10, 2019
I'm trying to customize the Earth 18 civs scenario, but I have come across a very annoying graphical glitch that happens when I try to put oceans next to land, to separate Australia from Indonesia. I know that there must be some way to resolve it, since the default oceans next to land up in Alaska/Kamchatka still work fine, but I've tried restarting worldbuilder, restarting civ, and even restarting my whole computer, but nothing seems to fix it. So if anyone has experienced this before, I'd love to hear how you solved it!

Also deleting the land and putting it back doesn't work either, because that automatically turns the adjacent ocean tiles to coast.

I do have Blue Marble installed. I hope that's not the problem because it was a pain to get it working properly with all my mods and such lol.
Screenshot 2022-11-10 141612.png


Traveler of the Multiverse
Jan 23, 2014
In a constant brainstorm...
That glitch is because you are trying to use ocean where coast should be. The game's graphics are simply not designed for that. If you see it working somewhere, that is only a lucky coincidence.
A possible solution could be to add another terrain type that uses the same graphics as coast but works as ocean. IIRC that needs dll changes too.
Top Bottom