1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Can't get mods to work

Discussion in 'Civ4 - Creation & Customization' started by Huayna Capac357, Aug 22, 2011.

  1. Huayna Capac357

    Huayna Capac357 Deity

    Joined:
    Jun 30, 2007
    Messages:
    8,194
    Location:
    Boston, Massachusetts
    I have tried mod after mod after mod, but I can't get any of them to work. Some examples include Leoreth's RFC Modmod, RFC Asia, and Fall From Heaven II. I install them correctly, and then when I load them from the main screen, the BtS screen disappears as normal. Then, a notice comes up saying "Beyond the Sword has stopped working."

    Further information: I use Civ IV Complete edition and have Windows 7. However, I have all the patches installed for BtS.

    Any ideas? There are so many awesome mods that I would like to be able to play.
     
  2. Baldyr

    Baldyr "Hit It"

    Joined:
    Dec 5, 2009
    Messages:
    5,530
    Location:
    Sweden
    You say that you've done everything correctly, while you most likely haven't. Otherwise you wouldn't have these issues, correct?

    Did you use the in-game auto-patcher, for instance? Well, that doesn't work with the last BtS patch. You have to download and install it manually. Otherwise mods simply aren't gonna work, period.

    Could you post a screen caption of your folder structure? Because simply looking at it would reveal any error from your part.

    Just trying to help. :p
     
  3. Huayna Capac357

    Huayna Capac357 Deity

    Joined:
    Jun 30, 2007
    Messages:
    8,194
    Location:
    Boston, Massachusetts
    Yes, I used the in-game auto-patcher. Could you give me a link to where I could find the latest patch?

    Also, here's a screen capture of my folder structure.
     
  4. vincentz

    vincentz Programmer

    Joined:
    Feb 4, 2009
    Messages:
    3,556
    Gender:
    Male
    Location:
    Denmark
  5. Huayna Capac357

    Huayna Capac357 Deity

    Joined:
    Jun 30, 2007
    Messages:
    8,194
    Location:
    Boston, Massachusetts
    Hmm...apparently I already have that patch. Should I uninstall it? Perhaps these mods are not compliant with this patch.
     
  6. The_J

    The_J Say No 2 Net Validations Super Moderator Supporter

    Joined:
    Oct 22, 2008
    Messages:
    33,396
    Location:
    DE/NL/FR
    What's ingame the version number?

    Are the default mods working?
     
  7. Huayna Capac357

    Huayna Capac357 Deity

    Joined:
    Jun 30, 2007
    Messages:
    8,194
    Location:
    Boston, Massachusetts
    I don't understand what you mean by this.

    Yes, they all still work.
     
  8. The_J

    The_J Say No 2 Net Validations Super Moderator Supporter

    Joined:
    Oct 22, 2008
    Messages:
    33,396
    Location:
    DE/NL/FR
    When you fire up BtS, you can find under advanced the option "about this build", where you can find the current version number of BtS.
    Should display in the first row 319, and in the third row 3.1.9.0.


    Oh, and did you install the latest patch for FfH2?
     

Share This Page