• Civilization 7 has been announced. For more info please check the forum here .

Civ 5 won't launch (Solved)

logic2718

Chieftain
Joined
Sep 21, 2015
Messages
7
I am on Windows 11 and Civ 5 won't launch. If I run it from Steam, the 2k launcher comes up, and then I press play. After that, the launcher closes and nothing happens. Steam says that the game is running. If I try to run it directly using the executable, nothing happens. Steam doesn't say that game is running, but a Civ 5 process does appear in Task manager.

Things I have tried:

Updating my graphics card drivers
Deleting the folder in Documents/My Games
Running Civ in compatibility mode
Turning off my anti-virus
Verifying integrity of game files: when I do this, it always says 6 files failed to validate
uninstall/reinstall Civ 5


The game worked fine a a couple of months ago. I just got my laptop back from the repair shop, where they replaced the RAM.

Any tips on how to proceed would be appreciated, thanks.


EDIT: Ok, I feel dumb, but the solution was just to wait. The game took around 5 minutes to launch. I'll mark this as solved, but if anyone has any idea why the game would take so long to launch, I'd appreciate it.
 
Last edited:
Top Bottom