Did I mess up SVN somehow?

Discussion in 'Civ4 - Caveman 2 Cosmos' started by garfunkel, Oct 12, 2019.

  1. garfunkel

    garfunkel Chieftain

    Joined:
    Aug 10, 2015
    Messages:
    47
    Clean Civ4 install. Downloaded v39 and put it in the right place. Ran SVN to a separate folder, copied/overwrote the C2C folder after it was done. Then ran SVN on the C2C folder to make sure everything was up to date.

    Got this error and a bunch of other XML errors.
    upload_2019-10-13_1-16-58.png

    This is GOG version, Civ 4 Complete.
     
  2. garfunkel

    garfunkel Chieftain

    Joined:
    Aug 10, 2015
    Messages:
    47
    I must have because a new, clean V39 install works.

    So I'm like 95% sure I did everything the same way I did back in V38 and V37. Has something changed?
     
  3. MattCA

    MattCA Prince

    Joined:
    Jan 25, 2019
    Messages:
    342
    Gender:
    Male
    it's best not to overwrite a copy of the mod with another copy.
     
  4. Harrier

    Harrier Deity

    Joined:
    Feb 19, 2002
    Messages:
    2,423
    Location:
    UK
    Do not overwrite, because this will not remove files deleted on the SVN. Those files unwanted (may/will) cause lots of errors in the game.
     
  5. billw2015

    billw2015 King

    Joined:
    Jun 22, 2015
    Messages:
    837
    Yeah you can use *either* v39 (or soon v40), OR SVN, they aren't meant to be merged.
     
  6. garfunkel

    garfunkel Chieftain

    Joined:
    Aug 10, 2015
    Messages:
    47
    Ah thanks, so that's what was going wrong! Thanks guys.
     

Share This Page