Help! System Hangs after Nimoy Introduction.


Sep 9, 2007
I have a 1.5 Ghz Compaq Presario X1000 with Mobility Radeon 9200 and widescreen.

I have been trying in vain to fix a problem with my Civ4/ with Warlords. :mad:

When the game is started on Single Player, the introduction with Nimoy begins and the cursor (which is a sword) is visible on a black screen with 'Autosaving' displayed on the left hand side. A worker is pointed at somewhere just outside the viewable screen. After a few minutes of speech after I click 'Play Game' the sword disappears, the computer hangs and crashes, locking me out of using any controls.

The game however works with no problems when I load up a scenario , such as 'Chinese Unification'

I have looked at a few different threads on here but have been unable to find a viable solution. I have tried updating my drivers with Omega Drivers but when I install them on my monitor the display comes out all wrong with parts of the screen repeating after one another.

This is driving me crazy!! Could someone please point me in the direction of maybe a previous thread that has the answer or just give me some clue as to what I could do.

All of your help will be rewarded 10 fold by my deepest gratitude!
Thank you so much for your reply. :)

No message appears, just an unforgiving unresponsiveness by the laptop that requires me to manually reboot it. :mad:

I have also tried using custom game to get through but still came up with the same result.

Right now, I have gone to my pc's manufacturer, Compaq, and searched to see if I have the most updated ATI display driver. It appears I did, until I went to the ATI website and found a more up-to-date version. I downloaded the new Catalyst software and now it gives me an error: "Severe: INF error Video driver not found." and a second dialog that states, " Setup was unable to complete the installation. Try to setup your display adapter with a standard VGA driver before running setup." :mad:

Do you know how I could resolve this issue or whether there is another way to get the Civ IV to work?
I am not too good in graphics card problems - does this error only occur when playing Civ or has the new driver screwed your whole system?
If it is only civ you could try disabling videos and/or lower your graphics settings (the latter won't help if it does not even recognize any video card).
I've had this problem since the day I installed CIV4,but fortunately it's easily sorted,at least on my setup.When I'm not Civing I'm flightsimming and have antialising set to high on my video card.I have to change this setting to application controlled before I fire up CIV otherwise I get the exact problem that you have described.Hope this helps.
Thank you for the post.

Where do you adjust the anti-aliasing setting. Under the CIV 4 screen I went into Advanced > Options and the anti-aliasing is already set to 0 with no other choices. :confused:

Could this be on another part of my computer?
You have a different video card to me so I don't know how to set yours. It might make it clearer if I tell you how I set my Nividia.
Right click desktop,properties,settings,advanced,GeForce 6600GT,Then tick box application controlled.
I tried the anti-aliasing thing but to no avail. I will try to uninstall Warlords and see if I can find the source of the problem. I used to be able to play Civ IV with no problem until I got the Warlords upgrade. I thought my computer met the necessary requirements based on the packaging.

Does anyone know if they have had similar problems with the Civ IV upgrade and were able to solve it?
Hi. Have you solved the problem? I've got the same laptop and the same problem occurred on my PC, when I try to start a single player game....
Top Bottom