• Civilization 7 has been announced. For more info please check the forum here .

How to increase Max Wonders per city?

ravenone

Warlord
Joined
Dec 13, 2005
Messages
113
Okay, here is another problem I can't figure out. How do you increase the max Wonders per city allowed from the default of 4 ? I've tried editing the GlobalDefines.xml file and setting:

<DefineName>MAX_WORLD_WONDERS_PER_CITY</DefineName>
<iDefineIntVal>-1</iDefineIntVal>

I've also tried other values such as 8, 99, etc. and this define does not seem to affect anything. I've searched and search and can't find where in the mod to change this max value so I can build more wonders in a city.

Anyone have any idea where to change this max value??

p.s. and Yes I'm changing it, then relaunching Civ4 and starting a new game each time, but the value is not being looked at.

thanks!
 
no one? I can't imagine that there is no way around the 4 Wonders max per city....
 
Are you sure to edit the correct file ? It has to be in Beyond the Sword\Mods\Rise of Mankind\Assets\XML

Works flawless for me.
 
Yup that is the one. I open it with wordpad, make the edit, then do a save of the file.

Maybe there is something weird with wordpad. Can I talk you into uplaoding your file and then I can just replace mine?
 
try clearing your cache, i edit this frequently whenever i want to play one city challenge, its always worked for me.
 
I have exactly the same problem, with other mods this method works fine but with RoM it doesn't
 
try clearing your cache, i edit this frequently whenever i want to play one city challenge, its always worked for me.

I've done that also and I still have a 4 World Wonder per city max.

Okay, I've tried using the non-megapack 2.5 mod version and it works fine. So, my problem and the possible bug is with the 2.5megapack that it does not look at this xml define setting.
 
How do you clear your cache?

Once you start to load Civ, hold down the Shift key while it continues to load. You should see as the various items load and progress bar moves, that one of the items listed is "XML (uncached) load" or something like that.
 
You'll need to change also the team wonder amount as in normal games 1 player = 1 team.


I did change that setting also(see below) but it still doesn't let me build more than 4 with the 2.51MegaPack.

Here is what my seetings in the GlobalDefines.xml are:

<Define>
<DefineName>MAX_WORLD_WONDERS_PER_CITY</DefineName>
<iDefineIntVal>-1</iDefineIntVal>
</Define>
<Define>
<DefineName>MAX_TEAM_WONDERS_PER_CITY</DefineName>
<iDefineIntVal>-1</iDefineIntVal>
</Define>
<Define>
<DefineName>MAX_NATIONAL_WONDERS_PER_CITY</DefineName>
<iDefineIntVal>-1</iDefineIntVal>
</Define>
<Define>
<DefineName>MAX_NATIONAL_WONDERS_PER_CITY_FOR_OCC</DefineName>
<iDefineIntVal>-1</iDefineIntVal>
</Define>
 
This must be a 2.51Megapack bug, cause the simple mod alterations work fine for me.
 
I did a clean install and then discovered I had a very old ROM version in the "My Games" folder under the BTS/Mods sub-folder. I removed that and now the 2.51megpack is working correctly and reading the XML file to allow more wonders per city!
 
I had the same problem, I'm using vista and notepad++ was saving GlobalDefines.xml to the virtual store. You can either disable UAC, change the permissions for the file\folder or save the file to the desktop and manually copy it into proper folder
 
when I clicked the xml file to increase max wondes, I got an internet page that said I don't have th program to read the xml file. Where can I get the program to increase the max wonders?
 
when I clicked the xml file to increase max wondes, I got an internet page that said I don't have th program to read the xml file. Where can I get the program to increase the max wonders?

Instead of double clicking on the file, right click and select to open with word pad or note pad to edit the file.
 
Top Bottom