• Civilization 7 has been announced. For more info please check the forum here .

Invalid Map File...?

Aarion81

Chieftain
Joined
Sep 30, 2010
Messages
4
I'm having trouble getting custom maps to load. I've downloaded several maps from the mod hub, and installed them. When I start a new game and go into advanced setup, I can see the maps I've downloaded, but they are all in red and say "Invalid Map File". Any ideas?
 
what map are you having issues with? Did you just install from the mod hub?
 
I have this problem with the modified European map of Dale's that someone added start locations to. I also have this problem with the modified world map from Rhye's civ mod. Both were downloaded via Steam mods section. I have other mods/maps from there that work fine, but these two maps/scenarios are both showing the above invalid map message in red text.
 
I get the problem with any and all maps I have so far downloaded from the hub. So far, that includes Land of Plenty, Rhye's converted Earth, and Dale Kent's Europe. I've tried uninstalling and reinstalling and that did nothing, so not really sure what to do at this point.
 
I am also having the same issue with these same maps...

Maybe it's something to do with the maps themselves then, and not anything on our end. That's a bit comforting to know I guess, although still disappointing lol
 
Yes but it must be an intermittent problem because a lot of people seem to be downloading these maps according to Steam and yet only 2 or 3 of us report issues here.
I suspect it is something like the mod "BITS transfer" error that was fixed in the last patch/update, we will just have to wait for the next update and hope it takes care of the problem.
 
There is also a sizeable post on this same issue over at the 2k forums, so I don't think it's just an isolated issue for 2-3 people.

I tried opening up a few of the maps in the Civ V world builder, and they won't even open in that. I'm thinking that some essential file or piece of data is getting lost in the transfer process, but I still have no idea how/why.
 
I made a map in WorldBuilder and wanted to package it into a mod file with ModBuddy. The reason was the hope that I could load it properly without going through Mods/Single Player so that I could actually save my game (can't save when playing a map from Mods). When I packaged it into a map mod, I also get Invalid Map File, even though it works perfectly a an individual map.
 
Same problem here, I've upload my map to the mod database but it reds out and says "invalid map file" if I download it from there. The original map that was already on my PC works just fine.
 
Same problem here. I've downloaded the maps "European Landmass" and "SPQR Europe". I can use them as is after download, but if I create a map pack using Mod buddy, adds one of these maps, builds the mod, loads it and tries to run it, then I get this problem.

Seems to be a bug in Mod buddy. There must be a workaround, I mean there are published mods including maps that works so... Anyone?
 
I finally found a workaround to the problem. For some reason it does not work to create a Map Pack in Mod Buddy and just add the maps, then you get the "Invalid map file" message.

The workaround that worked for me was:

1) With Mod Buddy, create a new "Empty Mod"
2) Add a new empty folder, Maps
3) Right click on Maps and select Add -> Existing item
4) Browse to the My Games\Sid Meier's Civilization 5\Maps folder and select the map you want. Repeat for all maps you want to include in the mod
5) Build the project
6) Go to the My Games\Sid Meier's Civilization 5\MODS\<name of your mod> folder, open your .modinfo file in a texteditor.
7) Below the closing </Files> xml-tag, manually add the entry points you need, for example:
<EntryPoints>
<EntryPoint type="Map" file="Maps/SPQR_Europe_edited.Civ5Map">
<Name>My borrowed edited map</Name>
<Description>A map of Europe, North Africa, and the Middle East.</Description>
</EntryPoint>
</EntryPoints>

I haven't tried with more than one entry point, since I only needed one. It works to put the map files directly in the root folder as well. The only difference I can see with a mod created in this way and the Map Pack automatically created by Mod buddy is that the Map Pack alternative does something to the map-file, since the date-time on the file is changed to the date and time when you build the mod. When doing it manually the date-time is not changed.

I hope this workaround will work for more people.
 
Top Bottom