• Civilization 7 has been announced. For more info please check the forum here .

[BNW] Loading modded game crashed after slight changes in mod

Lyokoheros

Chieftain
Joined
Mar 1, 2020
Messages
15
I've started a game with some collection of mods, this was supposed to practical testing of my new modded civ (which have some issues, working but incomplete version of it can be found on in this thread), with several other mods (including IGE, as it is great way for testing things I think), and it worked fine (well.. at that times when unique building didn't disappear...), I saved it after turn or two (and somewhat reshaping my surroundings), as mod wasn't complete yet.
Then I add some new changes to the mod - it was two unique improvement, which one was quite complex one, with many tech-unlocked and resource connected yields, second was a slightly different version of feitoria(it gives some terrain boost to help city-state it was build in) - both with used of already existing model and graphics. I also added some new features not connected specifically to this civ (like making desert tile yield 1 production, to make it not so useless, and make some improvements valid on features - because just why You can't have plantation in the jungle or forest or fishing boats on atol? For lumber mills in jungle there already is a mod, so I didn't include this). And when I started the new game it all worked fine. Desert yield was correctly set to not be additive with features (so hills, oasis, and flood plains give just their standard yields on the desert as intended), both improvement were possible to build etc.
But when I tried to load a saved game - which has exactly the same set of mods it didn't work. Game was loading the save all the time and couldn't finish it(it didn't exactly freeze as the animation wasn't stopped and I could move the cursor). And when I tried to open task manager it crashed. I never before encountered something like this, usually, it wasn't much of a problem to add new mod while loading saved game and I load this particular save before - many times with next and next changes so why it suddenly ceased to work all of sudden? Is there any way to solve this?

I didn't notice anything suspicious in the logs, all seems fine (beside errors which seems to appear also when it was working and not connected to my of this mod at all).
Spoiler Mods used: :

  • Better Liberty BNW + Venice (v. 1)
  • Celestia of Equestria (GK and BNW) (v. 5)
  • Dome of the Rock Wonder (v. 3)
  • DryingHut (v. 3)
  • Fewer Active Reliigions (v. 1)
  • Gondolin (v. 1)
  • Heralds of Sunset (v. 1)
  • Improved Windmil and Stoneworks (v. 1)
  • Improvement Lookout Towers (v. 1 )
  • Ingema Editor (v. 39)
  • Itsukishima Shrine Wonder (v. 2)
  • Lake Improvements (v. 3)
  • Lumber Mills on Jungles (v. 1)
  • Natural Wonders Enhanced (v. 1)
  • Palace Additions (v. 7)
  • Workable Mountains (v. 2)
  • XP from forts (v. 2)

I attach files with save and the version of my mod I tried to load this save. Working version You can find in previously linked thread.
 

Attachments

  • Doragoni z Equestrią.Civ5Save
    749.3 KB · Views: 53
  • Dragon Union - Doragon's civilization (v 1).rar
    18.3 KB · Views: 57
Top Bottom