Odd crash upon exiting game


Jun 29, 2018
Hi folks - I'm getting a strange crash (or crash-like behavior) whenever I try to leave a game in-progress. This affects loading saves once already in a game (the "load a modded save" menu has no issues), and also affects the "Return to Main Menu" and "Return to Windows" buttons. Upon attempting to load an existing save while in-game, or if either of the latter buttons are pressed, it will "load" for a few seconds, then proceeds to stutter a couple times before finally closing, with no warning. On rare occasions, I have received a "This application requested the Runtime to terminate it in an unusual way." message upon the game crashing(?), though again, this message only appears rarely.

I am on Windows 10 22H2, running Civ5 in DX10/11 mode. I play using STEAM. I have the expansions. My GPU is a NVIDIA GeForce RTX 3050.
I only play with mods enabled. In case they have some known issue, the mods being used are:
  • Several Touhou Project modded civilizations (workshop names and leaders listed):
    Seasoned Seasonals, Touhou Project Packs 1 and 2 (these first three are packs)... then Tengu Union (Tenma), Dream World (Doremy Sweet), Aran's Yukari Civ (Yukari Yakumo), Bhava-Agra (Tenshi Hinanawi), Aran's Alice Civ (Alice Margatroid), Eiki's Higan (ShikiEiki), Forest of Magic (Marisa Kirisame), Tanuki civ (Mamizou), Eientei (Eirin Yagokoro), Human Village (Keine Kamishirasawa), The Netherworld (Yuyuko Saigyouji), Oni Clans (Suika Ibuki), Moriya Shrine (Kanako Yasaka), Palace of Earth Spirits (Utsuho Reiuji), Probability Space Hypervessel (Yumemi Okazaki), Raiko's Tsukumogami (Raiko Horikawa), Makai (Shinki), Kobito (Shinmyoumaru Sukuna), Hakurei Shrine (Reimu Hakurei), Great Fairy Alliance (Cirno), Evil Spirits (Mima), Mugenkan (Yuuka Kazami)
  • Len'en Project modded civilizations: True Empire of Mugenri (Fumikado no Taira), Senri Shrine (Tsurubami Senri)
  • Cultural Diversity (partially - some parts I had to disable from loading, or were prohibited from loading by the game, because they had some kind of mod conflict)
  • InfoAddict
  • Only Mod Civs (last updated September 3rd 2013(!!!) apparently)
  • Sukritact's Events and Decisions
  • There are also some custom maps I've downloaded, but none of them had any special code associated with them as far as I can tell (I just had to move them to the maps folder). This crash is occuring even when the already-loaded save uses the vanilla map generation, so I don't think it's the maps.
Hello? Anyone?
I have the same issue. I hadn't played CIV 5 for several months. I had issues with CIV 5 crashing. That was solved (using compatibility mode using Windows 7) The program worked, except for the face that I cannot load more than one mod (Megamod Air, Land and Sea).
Top Bottom