• Paradox Games has announced today their new game “Millennia”, a semi-historical turn-based 4X game. Find out more here .

MPPatch - Easy Modded Multiplayer


Jun 16, 2017
MPPatch is a patch for Civilization V that allows mods to be used in multiplayer without specially preparing a mod pack, or anything like that. It basically adds back the multiplayer mods menu that got commented out, and makes it actually work. It currently supports Windows and Linux. I will eventually add Mac support. I don't currently have access to a Mac, so this could take some time.

It integrates LuaJIT for faster turns. This version of the patch works on all operating systems MPPatch supports. It (at least when it's stable), should obsolete the LuaJIT patch, MPMPM and modpacks.

The patch is not yet 100% stable, and there's probably still many undiscovered bugs remaining. Consider this version a prerelease.

Download latest version (v0.1.2)

For installation and usage instructions, read the user guide. If you have a bug, incompatibility or other issue to report, please make a post in this thread, or create an issue. You can find the source code here.

Spoiler Known Issues :
  • Some mods incorrectly set AffectsSaveGame to 0 when they define civilizations, etc. You cannot properly resume modded multiplayer games from saved games for these mods.
  • Sometimes when a user joins a modded lobby, custom civilizations will show as an "Unknown Leader". This can be worked around by having the users who show as an unknown leader changing their leader to another leader and back, or having the affected user leave and rejoin the lobby.
  • On Linux, sometimes the process doesn't properly exit when you quit the process. If this happens, you can kill the process by issuing a "killall -9 Civ5XP.orig" command. This appears to be a bug in the original game.
Spoiler Mod Compatibility :
Any mod incompatible with MPMPM will almost certainly remain incompatible with MPPatch. See that list here.

Beyonds that, I'm not aware of any further incompatibilities currently.
Spoiler Changelog :
Release 0.1.2
  • Fixes an issue that caused MPPatch to not load on Ubuntu.
Release 0.1.1
  • Fixes an issue that caused MPPatch to not load on Windows 7.
Release 0.1.0
  • Initial release.
Spoiler FAQ :
How do I ensure my mod is compatible with MPPatch?
First of all, MPPatch can't make any mod that isn't compatible with MPMPM and conventional modpacks suddenly work in multiplayer. That is to say, everything should be as deterministic as possible to avoid desyncs, and so forth.

Beyond that, see this document for considerations specific to MPPatch. These cases should (almost never) happen, but they are documented just in case.
Last edited:
Why in GODS name is it that no one has commented on this? This is amazing, I will see if it works tomorrow, my God if it does so tired of JdH's Civ V Mod Manager not supporting SQL files.
Is it possible to play scenarios at multiplayer with this, or at least transfer scenario parameters to the multiplayer with it? I would really like to play a map with pre-placed cities, territory and religions at multiplayer (one of my creation), but i'm not sure if it is possible.
Oh My God! This totally works! Been Looking for something like this for a long time since JhD's does not work with my custom mod! Thanks!
This Seems super cool, however when I use the installer, (v0.1.2) I get an error message whenever I launch Civ5. Any help would be greatly appreciated!
This Seems super cool, however when I use the installer, (v0.1.2) I get an error message whenever I launch Civ5. Any help would be greatly appreciated!

It's an issue with the new launcher, you have to use the old legacy launcher. To get it, do this:

  • Open up Steam and navigate to your LIBRARY.
  • Right click on the game in your library and choose "Properties."
  • Selected the "BETAS" tab.
  • In the text box to "Enter beta access for to unlock private beta:" enter the password "ineedlegacyaccess".
  • Click on the "CHECK CODE" button.
  • You should see a confirmation message that access has been granted.
  • If not already selected in the drop down, select "legacy" and click close.
  • Steam may require you to download and update for the game. Wait for this to happen or force it using "LIBRARY -> DOWNLOADS".
  • Once the game has been updated, click "PLAY" as usual and you will be running the legacy branch.
Has anyone experienced an issue where your civ/cities lose their Unique buildings after a resync happens? I just played a modded MP game a few hours ago and a couple of us were losing our UB because of this.

We did load a saved game after someone's monitor died 5 turns into the game.
Okay, I'm having some trouble... When I select mods, it goes through the process just fine. Then on the menu, I click Multiplayer. But then it say "Configuring Game Data" and then kicks me back to the menu. Any idea why?
So I've installed this and used this for a successful game of Civ V Modded Multiplayer with a friend, but I have another game with another friend with the Takmod, would this "break" that game? By which I mean causing problems to occur?
Hi. I've been pretty distant from this project for a while, mostly just between school and issues in my home life. That stuff has since calmed down a lot, and I have a lot more time to work on stuff like this now. So, expect updates to finish all the stuff I couldn't a few years ago soon. I've released a v0.1.3 containing experimental macOS support and a fix for the new Windows launcher. I've been unable to edit my post due to the spam filter, so I'll put the changelog here:

Release 0.1.3
  • Adds experimental support for macOS. This is not currently well tested, due to me not having consistent access to a macOS device.
  • Remove old and overkill mechanisms I used to reduce download size. The new downloads will be significant larger, but this isn't really a problem given modern download speeds. This will improve again when I switch off Scala for the installer.
  • MPPatch now works with the new launcher on Windows.
  • A few minor bugfixes. Nothing major has been fixed yet, but I've picked maintenance of this project back up.
I tried using the 0.1.3 version you currently have with Faerun for BNW and when I click multiplayer in the mod menu it does the loading thing and then immediately goes back to the main menu. SO i try just clicking multiplayer from the main menu and does the same thing like its stuck in a loop. not sure what could be causing it or why its even happening.
Is there a way to increase the amount of AI opponents in multiplayer?

The only way to increase them seems to be by changing the map size to something bigger.
Top Bottom