Opening savegames with the correct mod


Blue Period
Aug 23, 2009

I recently reinstalled Civ4 on a new laptop. On my old laptop, it used to be that when opening a savegame file, it would launch the mod the save was created for, and load the save immediately. Now I had to manually associate the *.civbeyondswordsave file extension with the Civ4BeyondSword.exe executable again, but that still only made it so that opening the savegame file would open unmodded BtS, and not actually load the game.

I am using Windows 11, and the GOG Civ4 Complete release of the game.

What can I do to load savegame files correctly?
Somehow the /fxsload param and the savegame file name need to be passed to the EXE. I imagine that Win 11 (which I have zero experience with) either ignores the respective registry keys or has prevented the installer from creating them. Perhaps, unless someone else has already solved this problem, you could locate the data created in the registry for the file association you've created and edit the command to something like (copied from my registry):
"C:\Program Files (x86)\Sid Meier's Civilization 4\Beyond the Sword\Civ4BeyondSword.exe" /fxsload="%1"
Replays and WB saves use the same command by the way.
That worked, thanks! Finding the correct registry entry was a pain but it turns out the /fxsload= parameter was missing and the "%s1" was just passed in as a positional argument.
Top Bottom