1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Trying to host a game to see if multiplayer works, getting errors.

Discussion in 'Bugs and Crashes' started by Theblade12, Oct 20, 2018.

  1. Theblade12

    Theblade12 Chieftain

    Joined:
    Jun 7, 2018
    Messages:
    5
    Gender:
    Male
    I'm trying to host a game on one of the most recent SVN builds (I've tried before that, though, so it's not limited to that one build) (Specifically a LAN one, since that's the only way I know how, and I figured it would be good enough to test) with two player-controlled civs (One host and one regular client) on the same PC, and when the game finally loads, I get this:
    Screenshot (367).png

    Does anyone know what might be causing this? I tried following the red error message's instructions by disconnecting- and reconnecting with my non-host client, but that didn't fix it. This time I started a new game, but with no events, since the error message at the top seemed like it could be referring to that, which also didn't fix the problem.

    Maybe the problem is caused by both of the clients being on the same PC? Or maybe regular multiplayer is just broken or something? Maybe it's because I'm using a LAN game?
     
  2. raxo2222

    raxo2222 Warlord

    Joined:
    Jun 10, 2011
    Messages:
    4,783
    Location:
    Poland
  3. KaTiON_PT

    KaTiON_PT Chieftain

    Joined:
    Jan 2, 2010
    Messages:
    842
    Location:
    Portugal
    I know that the most stable way to play MP is by emailing your save between players, where each plays its own turn.

    Either way, make sure each player have the same BUG options (share your UserSettings folder).
     
  4. Thunderbrd

    Thunderbrd C2C War Dog

    Joined:
    Jan 2, 2010
    Messages:
    24,747
    Gender:
    Male
    Location:
    Las Vegas
    Take a look at the list of advice points on setting up an MP game in the MP bugs and crashes thread. All systems must be running exactly the same filesets - exactly. Don't use events or Rev. All systems must be running the game as an admin. Start with that and see if it helps. OOS errors will come up now and then this way and maybe it's really in bad shape right now- I'm not sure. But that would be the best way to start seeing if you can get away with an MP game. It worked pretty good following those guidelines on straight v38.5.
     

Share This Page