1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Unplayable Multiplayer

Discussion in 'Civ5 - Technical Support' started by Siggy_23, Jun 16, 2012.

  1. Siggy_23

    Siggy_23 Chieftain

    Joined:
    Sep 30, 2010
    Messages:
    28
    My friends and I are having an interesting issue on every multiplayer game of civ 5

    Every time we get around turn 100, the game will hang for everyone on "waiting for players" though everyone had passed the turn. This problem was remedied by one of our players (it doesnt matter who) disconnecting and then remaking the game, however it reoccurs every 3-5 turns after that.

    It isnt a connection issue as we're all on the same wireless network and running constant pings to each other, and i certainly hope it isnt a RAM issue because we all have > 8 GB of RAM.

    Suggestions?

    EDIT: also, we have tried all restarting civ 5, that doesnt help either.
     
  2. dshirk

    dshirk Firaxian

    Joined:
    Oct 31, 2005
    Messages:
    879
    Could you post the latest auto-save from that game (turn before the issues start happening) and we'll take a look?

     
  3. DoctorHam

    DoctorHam Chieftain

    Joined:
    Jun 18, 2012
    Messages:
    4
    I'm experiencing almost an identical issue, except (1) we're playing over the net and (2) it's always me disconnecting at around turn 100. It's really frustrating because I would love to play with my friends, especially with Gods and Kings hitting tomorrow, but I can't. I've tried reinstalling Civ, validating my install through Steam, and reinstalling Steam, all with no success. We have tried with different people hosting, and even with me hosting, all with the same result. Nothing changed about my hardware or network to cause this.

    I have attached the last two autosaves from a game we played last night to see if the recent patch fixed things (it did not).
     

    Attached Files:

  4. DoctorHam

    DoctorHam Chieftain

    Joined:
    Jun 18, 2012
    Messages:
    4
    This continues to be an issue even after G&K's launch. Please help!
     
  5. pochesun

    pochesun Chieftain

    Joined:
    Jan 22, 2008
    Messages:
    22
  6. homelessinc

    homelessinc Chieftain

    Joined:
    Jul 19, 2012
    Messages:
    2
    Been having the same issue as well =(

    Also I think this might be the same issue posted here.
     
  7. Agoras

    Agoras Chieftain

    Joined:
    Jul 18, 2012
    Messages:
    2
    Yeah this Is becoming incredibly frustrating. Something needs to be figured out! Ive got 5 games going with friends going and cant finish any.
     
  8. Mandalore

    Mandalore Chieftain

    Joined:
    Jul 27, 2012
    Messages:
    1
    I'm also running into this issue. I've tried multiple games with different groups of players and every game has eventually become unplayable due to it hanging on "waiting for players".
     
  9. synformis

    synformis Chieftain

    Joined:
    Jul 30, 2012
    Messages:
    1
    We have all the same content and version but on Mac OS X Mountain Lion and purchased/downloaded from Mac Appstore. Doesn't matter who starts the game, still have connection issues after random amount of turns. Tried saving and reopening the game, but that doesn't resolve the issue. We're playing on same network and have not had issues prior to the recent update of G&K and Mountain Lion. Will keep reading for any updates on the issue.
     
  10. DoctorHam

    DoctorHam Chieftain

    Joined:
    Jun 18, 2012
    Messages:
    4
    I am still having this issue, just tested it last night and I crashed at turn 34. Please, please can someone provide a fix for this?
     
  11. DoctorHam

    DoctorHam Chieftain

    Joined:
    Jun 18, 2012
    Messages:
    4
    I fixed it, with the help of this thread.

    The solution was to go into your Device Manager, uninstall your NIC (but do NOT delete driver software), and then reboot your computer. This refresh of my NIC seemed to resolve the problem, as I was in a multiplayer game with my friends last night with no disconnects through when we called it quits for the night around turn 200.
     
  12. TheHanzou

    TheHanzou Chieftain

    Joined:
    Feb 20, 2012
    Messages:
    93
    Yes i had the same problem around 2 weeks ago. Reinstall network device driver works.
     

Share This Page