Worldbuilder issue (BUG conflict?)

Coolguybest

Chieftain
Joined
Sep 6, 2022
Messages
1
I recently got back into playing Civ 4, installing the BUG mod onto an otherwise unmodded BtS Civ 4 game. Everything works fine, but I noticed something odd- when I'm in the worldbuilder, the map reveal/un-reveal tool does not work. On selection, the game pauses for a second then does nothing upon resuming. The fog tool does not start, I cannot modify what is and isn't discovered, etc. A second oddity that I've noticed is that when alt-tabbing out of the game and re-entering, the worldbuilder re-selects the unit tool and duplicates the tabs of the map editor section without copying over their contents (that is, the first four tabs have all their usual items, but any tabs afterwards (as this can be repeated to re-duplicate the tabs) are completely empty).

I thought this was an oddity with the BUG installation, but when I uninstalled it, the glitch persisted. A complete un- and re-install of BtS, even before re-installing BUG did not alleviate the problem. What's further confounding is that, to my memory, before I installed BUG, the map reveal/un-reveal tool worked perfectly fine.

Does anyone have any ideas or suggestions over what I could do?
 

lymond

Rise Up! (Phoenix Style!)
Moderator
Hall of Fame Staff
Joined
Mar 11, 2008
Messages
24,042
I recently got back into playing Civ 4, installing the BUG mod onto an otherwise unmodded BtS Civ 4 game. Everything works fine, but I noticed something odd- when I'm in the worldbuilder, the map reveal/un-reveal tool does not work. On selection, the game pauses for a second then does nothing upon resuming. The fog tool does not start, I cannot modify what is and isn't discovered, etc. A second oddity that I've noticed is that when alt-tabbing out of the game and re-entering, the worldbuilder re-selects the unit tool and duplicates the tabs of the map editor section without copying over their contents (that is, the first four tabs have all their usual items, but any tabs afterwards (as this can be repeated to re-duplicate the tabs) are completely empty).

I thought this was an oddity with the BUG installation, but when I uninstalled it, the glitch persisted. A complete un- and re-install of BtS, even before re-installing BUG did not alleviate the problem. What's further confounding is that, to my memory, before I installed BUG, the map reveal/un-reveal tool worked perfectly fine.

Does anyone have any ideas or suggestions over what I could do?
I'm not heard of this issue at all. If you are using the Steam version of BTS make sure you switch to the Beta version. Mods will not work otherwise.
 
Top Bottom