1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Buffy Mod errors

Discussion in 'Civ4 - Technical Support' started by LANCE1313, Apr 17, 2020.

  1. LANCE1313

    LANCE1313 Chieftain

    Joined:
    Apr 16, 2020
    Messages:
    24
    Gender:
    Male
    Just trying to install the Buffy mod to take part in GOTM. I've got BTS 3.1.9 installed and when I enable the mod I get the error " Warning: THe HOF Mod will be unable to save setting. Games played will NOT be valid for submission..."

    I've followed the forum advice to adjust properties including "Full Control" under Security tab and "running as admin". I've also changed the compatibility mode to a few different settings including Windows XP SP2 and SP3.

    This is a GOG install. I've seen forum posts regarding issues with STEAM installs but I don't believe this is relevant to me.

    The error continues regardless. I'm not sure where to go from here.
     
  2. drewshark

    drewshark Proud Father

    Joined:
    Dec 4, 2002
    Messages:
    115
    Location:
    Scottsdale, Arizona,U.S.A.
    i too am having an error after installing the buffy mod and trying to download and play a past GOTM. I have been gone from CIV for many years but am trying to get back into it. I have re-downloaded my game from direct2drive and it came w a patch included to d2d beyond the sword v 1.74. I have no idea if this is the most updated form of the game or if I need an additional patch but it worked fine in single player mode and before I tried the buffy mod download install and then tried opening the save file from the GOTM I open the file and get the prompt "The save file you have selected requires the following mod to be loaded...mods\buffy-3.19.005\"..I hit "ok" and then get some kind of lock up with the error message "mods\\\buffy is an invalid mod directory, ignoring ok?" and then it starts all over...at some point in the upper part of the load screen i get a flash of "TXT-KEY_Menu etc etc" before crashing...

    Any help is appreciated...it's been a long time and I'd like to be able to play the GOTM again on here.
     
  3. Les Baker

    Les Baker Chieftain

    Joined:
    Apr 3, 2020
    Messages:
    4
    Gender:
    Male
    Hi am having almost the exact same thing as Drewshark, through a Steam installation.I have installed the GOTM Conteder save file to my regular Saved Games file but when I select it I get the same message "The save file you have selected requires the following mod to be loaded...mods\buffy-3.19.005\" "The applicationmust restart OK?" then it just goes into a loop before my whole machine has to be restarted to get out of the screen I dowloaded the BuffyMod previously from the GOTM and noticed that the download is mods\buffy-3.19.003 instead of 005. Can someone in tech support please help as this may be something obvious? Although I downloaded the mods\buffy-3.19.003 Mod before, my regular play is still running under the BUG mod.Les
     
  4. lymond

    lymond Rise Up! (Phoenix Style!) Hall of Fame Staff

    Joined:
    Mar 11, 2008
    Messages:
    22,118
    Mods will not work with the default install of Steam as they change assets to work with their MP. You need to switch to the "Beta-original release". But first I recommend a fresh install. Uninstall in Steam and then make sure to delete all civ related files and folders under Programs and My documents.

    Reinstall in Steam. Then click on properties > Betas tab > select Beta -original release. Steam will reinstall the game.

    After it installs go here to download BUFFY 005 version, and take note of the Vista Fixes tab, and perform all steps in step 1 and 2:
    http://hof.civfanatics.net/civ4/mod.php

    Important: Always run BTS from the executable which you can pin to Quick Access in Explorer. Do not run from Steam Library

    (Note: BUFFY is standalone. Having BUG installed standalone or in Custom Assets is fine as well. However, if you have BULL DLL installed the BULL DLL file cannot be active if running BUFFY and trying to play BOTMs. Reason is those games are created with Lock Modified Assets option turned on so game assets must match between source and target. It does not impact games you create yourself though)
     
    Last edited: Apr 24, 2020
  5. CowboyCub

    CowboyCub Chieftain

    Joined:
    Feb 1, 2018
    Messages:
    4
    Gender:
    Male
    I've got the same issue as LANCE1313, I've set the folder permissions to remove the read only access, changed the game to run as admin, reset all the security parameters to full access and even created a second user on my laptop with admin access, but no matter what I do I get the dreaded "not eligible for BOTM games, use an account with admin access" error message. This is a GOG download and I am running windows 10, anyone been able to get this to work?
     
  6. Edarga

    Edarga Chieftain

    Joined:
    Oct 11, 2020
    Messages:
    1
    Gender:
    Male
    Same issue with a GOG download. So have any GOG users got this working? I'd love to join in the games, but this error keeps me from it.
     
  7. Pangaea

    Pangaea Rock N Roller

    Joined:
    Sep 17, 2010
    Messages:
    5,570
    I have the GOG version and got it working, but I'm on Linux so am not sure what would be required on a Windows system. I would think it should work more or less out of the box. Tagging @lymond in case he hasn't seen your post yet.

    Maybe this is done already, but a general recommendation is to not install in Program Files. Lots of extra security (if one can call it that on a Windows system) there that can mess up the programs running properly (yeah... woot). Hence all this bending backwards with giving full admin rights and stuff (a huge security problem in itself, but should be fine here as we're not talking about dodgy software).

    Another possible issue is a couple of registry settings in the GOG version of the game. I don't know if these have been fixed by now, but it's possible it causes some problems with the Buffy mod if not. Given the error message, maybe that's not it, tho.
     
  8. lymond

    lymond Rise Up! (Phoenix Style!) Hall of Fame Staff

    Joined:
    Mar 11, 2008
    Messages:
    22,118
    @Noble Zarkon has a gog fix I believe. There is a known issue with the gog version

    edit: Just realizing now that this thread is in the tech forum. Not sure why I did not pick up on that the first time. Should be in HOF forum.

    @LANCE1313
     
    Last edited: Oct 13, 2020
  9. Noble Zarkon

    Noble Zarkon Elite Quattromaster - Emperor (BTS) Moderator Hall of Fame Staff Supporter GOTM Staff

    Joined:
    Sep 6, 2012
    Messages:
    5,626
    Gender:
    Male
    Location:
    Gibraltar
    @Edarga - PM me your full installation path (e.g. C:\GOG Games\Civilization IV Complete\Civ4\Beyond the Sword\) and I'll send you the registry fix.

    @CowboyCub same for you, apologies never saw your post for some reason. Will update the Mod page to flag this up.
     
  10. lymond

    lymond Rise Up! (Phoenix Style!) Hall of Fame Staff

    Joined:
    Mar 11, 2008
    Messages:
    22,118
    Are you still around? Still need help? This really is not the proper forum for the OP, Regardless somehow I missed your post months ago. I’ve had a d2d version for many years. It is perfectly fine. So we’d need to work together to identify where things went wrong with your install.
     
  11. lymond

    lymond Rise Up! (Phoenix Style!) Hall of Fame Staff

    Joined:
    Mar 11, 2008
    Messages:
    22,118

Share This Page