1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Can't get FFH2 to work with steam install

Discussion in 'Fall from Heaven Troubleshooting' started by Siderealex, Jun 28, 2009.

  1. Siderealex

    Siderealex Chieftain

    Joined:
    May 12, 2009
    Messages:
    99
    Okay so I followed the path advice the mod said if you have Civ 4 on Steam. I downloaded the patch for compatibility with 3.19. But when I try to click on the FFH 2 shortcut I get an error that says Mods/Fall from Heaven 2 /is an invalid mod directory, ignoring..

    It then opens up the regular Beyond the Sword, and FFH2 is not an option on the mods menu.
     
  2. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,912
    The result you are getting is consistent with FfH2 being installed in the wrong location.

    What is that path advice you mention? I'd like to help but I don't know what advice you got.
     
  3. Siderealex

    Siderealex Chieftain

    Joined:
    May 12, 2009
    Messages:
    99


    Where it says,
     
  4. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,912
    Your folder "C:\Program Files\Steam\steamapps\common\sid meier's civilization iv beyond the sword\Beyond the Sword\Mods" should look something like this:


    Of course, you will have additional folders if you have installed any other mods. The important thing is that you see a "Fall from Heaven 2" folder there. If you don't, then the correct path was not supplied to the installer.

    The contents of the "Fall from Heaven 2" folder should look like this:


    If you see a folder inside the "Fall from Heaven 2" folder called "Fall from Heaven 2" the path "C:\Program Files\Steam\steamapps\common\sid meier's civilization iv beyond the sword\Beyond the Sword\Mods\Fall from Heaven 2" was given, and that is incorrect.

    It is also possible that the problem is not the location the mod was installed, but rather the shortcut itself. If you right-click the shortcut icon and choose "Properties" from the context menu that opens, and then look on the "Shortcut" tab of the properties window that opens, you should see that the "Target:" is
    Code:
    "C:\Program Files\Steam\steamapps\common\sid meier's civilization iv beyond the sword\Beyond the Sword\Civ4BeyondSword.exe" mod=\Fall from Heaven 2
    and "Start in:" should be
    Code:
    "C:\Program Files\Steam\steamapps\common\sid meier's civilization iv beyond the sword\Beyond the Sword\Mods"
    You should be able to get the shortcut to work if those entries are incorrect and you correct them.

    If that won't fix the problem then try loading Civ4 normally and then load the mod from the main menu. If that won't work then the mod is not installed correctly. I would suggest consulting my guide to installing FfH2, linked below in my sig. Start with the "Recovering from a failed installation attempt" section.
     
  5. Siderealex

    Siderealex Chieftain

    Joined:
    May 12, 2009
    Messages:
    99
    That's what my Mods folder looks like. The Fall from Heaven 2 folder is there, and it's content looks like that.

    I've tried opening Civ 4, and Civ 4 Beyond the Sword. Neither have the mod available on the list of mods I have. I consulted the guide and went through its steps. I still get the same error message when I try to use the shortcut.
     
  6. Siderealex

    Siderealex Chieftain

    Joined:
    May 12, 2009
    Messages:
    99
    I also checked the shortcut paths and they are what they should be.

    Edit. Figured out the problem. When I got the error I noticed something odd. Name the Mods/Fall from Heaven 2 /is an invalid mod directory, ignoring..the / at the end. Apparently when creating the shortcut my computer wasn't adding the " that needed to be at the end. Added it and the mod works. Go figure :)
     
  7. azatol

    azatol Chieftain

    Joined:
    Jan 14, 2007
    Messages:
    111
    Location:
    Elk Rapids, MI
    I can't get Ffh to work either. Both loading the mod through the game, or clicking on the link crash the game for me.

    I've verified I have 3.1.9. And I'm using steam also. What else could be my problem? I checked, and Ffh is in the right folder, under the mods in BTS. Civ 4 detects it and everything but it crashes when loading.
     
  8. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,912
    You may not have installed the latest patch. In order for FfH2 0.41 to work with v3.19 you have to download and install patch B, which is linked in the first post of the FfH2 Bug Thread.
     
  9. azatol

    azatol Chieftain

    Joined:
    Jan 14, 2007
    Messages:
    111
    Location:
    Elk Rapids, MI
    Ah, that's my problem
     
  10. snaf2

    snaf2 Chieftain

    Joined:
    Jul 26, 2010
    Messages:
    2
    I'm having similar problems to everyone in this thread, but none of the advice given has worked for me.

    I've checked and double checked the advice and have followed it to the letter.

    My version of the game is saved onto an external harddrive (F:) and I've amended the file directory in the shortcut to reflect that.

    I notice when loading the Mod from the in-game Advanced menu that there's one listed as Fall from Heaven 2 and another listed as Fall from Heaven 2 2023c. The first of these tries to load and then brings up the GFC Error message. The second just closes Civ IV and then does nothing at all.

    Any ideas??
     
  11. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,912
    I'm not sure why you have two FfH2 installs. Perhaps you have installed two different versions. I suggest that you delete all versions of FfH2 that you have installed currently, and the installers/patchers that you used to install them, redownload the full mod from the link in the first post of the FfH2 Bug Thread, and reinstall the mod. This will ensure that you are using the latest version of FfH2, and allow you the opportunity to notice any problems with the installation process.
     
  12. Nor'easter

    Nor'easter Chieftain

    Joined:
    Feb 25, 2007
    Messages:
    1,247
    @Emptiness:

    Fall from Heaven 2 2023c is the last version for Vanilla Civ 4 (before the BtS conversion). That's why he has two versions of FfH.

    I agree with your suggestion for what he should do, but thought I should clear this up.
     
  13. Emptiness

    Emptiness []

    Joined:
    Jan 7, 2009
    Messages:
    1,912
    Ah, okay. Thanks for the correction. It probably isn't necessary to mess with that one, then - if it is working correctly. I've never used it, so I don't know if it still works after BtS is installed.

    So my amended suggestion is to delete the "Fall from Heaven 2" folder and reinstall with a freshly downloaded copy of the full installer (2009_05_16_FallfromHeaven2041n.exe).
     
  14. Nor'easter

    Nor'easter Chieftain

    Joined:
    Feb 25, 2007
    Messages:
    1,247
    I was able to play the last vanilla version of FfH after I had BtS by using the vanilla Civ 4 disk, since I'd bought vanilla Civ 4, Warlords, and BtS all separately.

    I did that only once, though: although I think Kael should have kept some of what he ultimately removed, the BtS version of the mod is MUCH more interesting than the vanilla version.
     
  15. snaf2

    snaf2 Chieftain

    Joined:
    Jul 26, 2010
    Messages:
    2
    just replying to say thanks for the advice. as it happened i'd been trying to install vanilla civ iv version in BTS directories. Stupid mistake and when i d/l the BTS version it all works fine.
     
  16. Shadow World

    Shadow World Chieftain

    Joined:
    Sep 16, 2007
    Messages:
    22
    I know this is a really old post but I found another way to install if having this same issue. Install to this path
    "C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization IV Beyond the Sword\Beyond the Sword\Mods"
    now find "Civ4BeyondSword_PitBoss" it will be in the same file as "Civ4BeyondSword.exe"
    Run pitboss and you will see fall from heaven II in the list of mods. Select it and it will make a functional desktop icon.

    Cheers
     

Share This Page