1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ IV Crashes Because of MSVCP71.dll

Discussion in 'Civ4 - Technical Support' started by Comrade_Angel, Jan 11, 2014.

  1. Comrade_Angel

    Comrade_Angel Chieftain

    Joined:
    May 28, 2012
    Messages:
    11
    So, I was trying to play History Rewritten, happy to get back into such a wonderful mod, when suddenly...:

    "Civilization IV Beyond the Sword has stopped working."

    And then it all crashed to my desktop with no errors, no reports, nothing but that generic Windows window giving me the options to either close the game or search online for a solution before closing the game. I just shrugged this off as my computer being derpy, as it has been known to bug out and crash with Civ before. I loaded the mod up again and tried to start a new game again...only for it to crash a few seconds after I clicked to start, when it should be generating the map and doing its thing. A bit irked, I tried again. And again. And again. And once again. I began using a different civilization and different map settings each time in case it was just a specific thing causing the crash, but nothing worked.

    This is really annoying because I can never remember a mod just crashing immediately after clicking the button to start the game, and I've never had this issue with the mod before. I haven't edited anything in the mod at all since the last time I played, but just in case I completely deleted the History Rewritten folder, re-downloaded it, and unzipped it straight to the Mods folder, making sure it wasn't double nested or suffering from some generic, common issue. The situation stayed exactly the same.

    So, in summary, the game immediately crashes to the desktop after I click to start the game, no matter what civilization or map settings I have, in all of the various menus to start games, with no discernible cause, except for the following Windows report:

    Spoiler :
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: Civ4BeyondSword.exe
    Application Version: 3.1.9.0
    Application Timestamp: 4a0c27e6
    Fault Module Name: MSVCP71.dll
    Fault Module Version: 7.10.3077.0
    Fault Module Timestamp: 3e77eebb
    Exception Code: c0000005
    Exception Offset: 000078aa
    OS Version: 6.1.7601.2.1.0.768.3
    Locale ID: 1033
    Additional Information 1: 8485
    Additional Information 2: 84853502223d8164a31468861a7c3d71
    Additional Information 3: a4ea
    Additional Information 4: a4eacf9d27e5ee8cb3a70ac0035eb8ab


    The mod maker says that it might be the ''MSVCP71.dll' that's causing it to crash like this, so I figured I'd hop over here and ask about it.
     

Share This Page