1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Crashes on Mods Screen

Discussion in 'Civ5 - Technical Support' started by TheZombifiedGuy, Oct 12, 2015.

  1. TheZombifiedGuy

    TheZombifiedGuy Chieftain

    Joined:
    Aug 31, 2012
    Messages:
    9
    So as a preface, I run a lot of mods in Civ V. And I do mean a LOT. All sorts of modded civs, R.E.D., EUI, you name it. Normally they work fine together, or if they don't I can isolate which one is causing the issue and remove it.

    However, like other people, I suffer from mods I subscribe to on the Steam Workshop not always appearing on the mods list, or not properly reappearing when I hit "update" from the mods screen. I've gotten around some of these by downloading the mods manually (using http://steamworkshopdownloader.com/), but every now and again another mod I got from the workshop will go astray. Previously, when this happened, I followed the advice of various posts on CivFanatics and elsewhere and deleted the cache folder in the Civ V folder, and this would force the game to re-download the missing mods.

    But now, for some reason, this trick doesn't work anymore. Maybe a month or so ago I tried clearing the cache and upon getting to the mods screen, the game would start to re-download my mods, and then freeze at a non-specific point in the process. No matter what I did this kept happening, so I eventually just gave up and left it alone, and somehow the issue fixed itself maybe a week later. Today, though, I had some mods disappear again and so made the (rather inadvisable, in retrospect) decision to try deleting the cache again to see if this fixed it, but it crashed again.

    Sometimes it'll crash immediately after clicking the "Mods" button on the main menu, right as the mods list appears. Other times it'll start to download my mods, and then crash partway through. After exiting and re-opening the game at that point, I can sometimes get to the mods screen without a crash and then use a (typically much more limited) list of my mods, which I think is based on which mods are smallest (or were downloaded first, I'm not sure).

    Things I've tried to fix the issue: Restarting Civ, restarting Steam, deleting the cache folder, deleting my "MODS" folder, restarting my computer, re-opening Civ after a crash to activate what mods made it through, hitting next, and then (when it loads) exiting the game and trying one of the above again. I've tried all these in varying orders (looking for a magical succession of gimmicks that will make everything work as normal, but no luck so far). On a hunch I also tried removing EUI from the DLC folder, thinking that maybe the issues had started when I installed it a few months ago, and while I made a promising amount of progress in downloading the mods after this, I eventually got a different crash altogether where the screen turned black (with the Civ V cursor still visible and movable), and then the game CTD'd, and I guess took Steam with it because Steam stopped responding too.

    Anyone have any suggestions? (Also sorry for the long post, wanted to explain as much as I could, though I'm not very technically savvy)
     
  2. ragan651

    ragan651 High Regent of Candlewick

    Joined:
    Jul 9, 2012
    Messages:
    328
    Location:
    NW US
    Tried unsubscribing from mods, then resubscribing? Sometimes Steam workshop can get a little crazy, and unsubscribing from something and then subscribing again can get it working.

    Also, although it is time consuming, try unsubscribing from everything, deleting the mods if they aren't removed, deleting the cache, restarting Steam, then resubscribing to everything.
     

Share This Page