• Civilization 7 has been announced. For more info please check the forum here .

[GS] Freezing, glitches and computer suddenly hibernating?

JRRivett

Chieftain
Joined
Jun 15, 2020
Messages
1
Hi,

I'm new to the forum because I've never really had a problem with the game before.

Now, having just got a new laptop - an XPS 15 - I've found the game is basically unplayable. This is strange because in every way this computer is much more powerful and capable than my previous one which never had a problem running the game.

I'm wondering if what I'm experiencing is a known problem and easily fixed. Here's what I've found:

- The game runs OK for between 5 and 15 minutes (although I've noticed some of the voices are echoy).
- After a while the game does one of the following: freezes and I can only get it going again by pressing the Windows key; it gets coloured glitchy lines across the map and freezes so that I can only get it going again with Windows key or by closing and opening the lid and using the fingerprint sensor to log back in; or the screen goes black, briefly shows a "Loading" message and then the computer appears to either go into hibernation or sleep mode.

I've noticed the laptop gets reasonably hot while I'm playing and the fans get going very quickly, and I've read that the random nature of the hibernation/sleep/glitches could point to an overheating problem. (This is a bit of a worry again given the older, much less powerful laptop I own has never had such a problem.)

Here's my laptop specs:

16 GB

512GB M.2 PCIe NVMe Solid State Drive

Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz[Cores 6] [Logical/Core 2]

GeForce GTX 1650 Ti


I've updated all the drivers and have the latest, recommended BIOS installed.

Any help would be great, thanks.
 
Top Bottom