1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

game won't launch (nothing happens after clicking): troubleshooting and solution

Discussion in 'Civ5 - Technical Support' started by Mannu, Sep 22, 2010.

  1. Mannu

    Mannu Chieftain

    Joined:
    Sep 23, 2005
    Messages:
    230
    Here's my problem and how I worked around it.

    I updated everything through steam to the point where I was able to click "Play" and then a little window of the CIV5 app would appear with text links to ask me to choose either DirectX9 or DirectX10-11 to play CIV. When I clicked on either of those nothing would happen.

    On this screen though, you can right click on either of those links and choose to create a desktop shortcut. Create a shortcut for the one you prefer to use.

    Now when I tried to launch the game using this shortcut, I got an error message about a missing directX .dll file.

    I reinstalled DirectX from here: http://www.microsoft.com/downloads/en/resultsForProduct.aspx?displaylang=en&productID=9C954C37-1ED1-4846-8A7D-85FC422D1388
    It's the one at the very top. Always install the latest and greatest and always only from Microsoft.

    Then I restarted and CIV5 is now working for me, well mostly. I don't have any intro video, but if I wait a few seconds the game loads. Also leaders are not animated (though I wonder if that is a display setting).

    Good luck!

    P.S. if you aren't sure what version of DirectX your PC has, then search your pc for the dxdiag.exe and run that. It's an application that gives you details about your directX install (and your display adapters and monitor).
     
  2. The_J

    The_J Say No 2 Net Validations Retired Moderator

    Joined:
    Oct 22, 2008
    Messages:
    29,620
    Location:
    Germany / Netherlands
    Thanks for posting this :).
    I'd like to see a confirmation that it works for someone else.
     
  3. rage1907

    rage1907 Chieftain

    Joined:
    Sep 22, 2010
    Messages:
    1
    I'm having the exact same problem but this solution didn't work for me. I've tried most of the solutions for directx related problems but nothing works. Atleast it's only the demo. I'm a major civ addict so unless I find a solution soon, I' will get me a brand new computer and hope that will do the trick :/

    Anyone who solves this issue using another solution: please notify us here. thanks!
     

Share This Page