1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Investigating crashes

Discussion in 'Civ5 - Creation & Customization' started by Frossa, Oct 27, 2014.

  1. Frossa

    Frossa Chieftain

    Joined:
    Apr 29, 2012
    Messages:
    409
    Gender:
    Male
    Location:
    Sweden
    Attempting to playing a game with my mod, and I keep getting the game to crash with a "blabla.exe has stopped working"-message on turn 2, always as the game processes the turn for a specific Civ. When I start a new game to hopefully bypass whatever errors occurred, the game crashes on Turn 2 again, but this time while it processes another Civ's turn. In what logs am I supposed to be looking for the source of this seemingly sporadic malfunction?
    If it's just the net_message_debug log, this is what the last three rows there have to say:
    Code:
    [31520.813] DBG: CheckPlayerTurnDeactivate() : auto-moves complete for Napoleon
    [31520.813] DBG: changeNumGameTurnActive(-1) m_iNumActive=0 : setTurnActive() for player Napoleon
    [31520.813] DBG: changeNumGameTurnActive(1) m_iNumActive=1 : setTurnActive() for player 9 Maria Theresa
    player Napoleon being me, and Maria Theresa being the AI the game crashed on. All I can tell from this is that the game initiated Austria's turn, and then nothing happened, since it crashed.
    Is there anywhere I can look deeper into what caused this, out of all the logs?
     
  2. ls612

    ls612 Deity Moderator

    Joined:
    Mar 10, 2008
    Messages:
    8,068
    Location:
    America
    Are you using a mod with a modded DLL? Also, do you have lua logging enabled?
     
  3. Frossa

    Frossa Chieftain

    Joined:
    Apr 29, 2012
    Messages:
    409
    Gender:
    Male
    Location:
    Sweden
    I'm using Putmalk's Civ IV Diplomacy Features, and Lua logging is enabled.
    EDIT: I tried disabling Putmalk's mod, but still the same error. Doesn't seem to be related to a modded DLL.
     

Share This Page