Laptop fan taking off with Civ4

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
37,076
Location
東京藝術大学
Whenever I launch Civ4 my laptop fan immediately starts to run at full capacity. This is a behaviour I usually only start to see on very CPU/GPU intensive applications (other games like Victoria 3). Civ4 is not so resource hungry to cause this, and on my previous laptop it usually ran fine without triggering it's fan into high gear. Additional evidence that things are weird is that this happens immediately - even when Civ4 is only running in the main menu, with nothing CPU taxing going on.

Civ4Resources.png


Here we can see that Civ4 has a low CPU footprint on my system.

dxdiag info in case it is relevant:
Screenshot 2024-03-18 153132.png
Screenshot 2024-03-18 153148.png


Does anyone have any idea what the cause could be? I am fairly sure that there is not enough CPU load to justify the fan response. Is there something I could do to configure my fans to better respond to this without risking overheating?
 
Your GTX 3070 Ti probably activates when CIV starts, since it is a graphically "intense" program. When the NVIDIA gpu on my laptop activates (GTX 1650), it draws an extra 35 - 45 W, even at idle. Perhaps your laptop is kicking the fans on to dissipate the extra heat from the GPU?
 
That makes sense, I will investigate that. Thanks!
 
That was exactly it, thanks again for pointing me in the right direction. Civ4 ended up drawing about 30-40% GPU load even when minimized, compared to ~0% when the system is idle.

After a bit of looking I found that the game was set to "performance mode" in the Windows graphics settings (probably a default for anything considered a video game) which made it default to the primary GPU. However you can set the application to "power saving mode" which makes it use the built-in mainboard GPU instead, which is good enough for Civ4's modest needs from what I can tell. Instead of 30% Geforce load I now get 70% on the built-in, and much reduced noise and probably power consumption.

Here's where you can set it in case anyone else needs the information (Windows 11):

Screenshot 2024-03-23 161412.png
 
For anyone else looking for this later, with Windows 10, it's in essentially the same spot. Display -> Graphics Settings (or just search for "Graphics Settings" on the Start menu/screen). There isn't a searchbar like in 11, so you'll have to browse to where Civ's .exe file is to customize it, but it should work much the same.
 
Top Bottom