1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Launching DX10 and screen shows DX9?

Discussion in 'Civ5 - Technical Support' started by JoxerNL, Mar 8, 2011.

  1. JoxerNL

    JoxerNL Warlord

    Joined:
    Oct 2, 2010
    Messages:
    192
    Hi there, not really a technicall problem so posting it here. Moderator Action: That's definitely a technical problem. Threads merged + moved.
    After abit of a break due to RL stuff i started my Civ V up again.

    However after launching it from steam i did not get the Civ V "Launcher" display it just started the game, and when it started the topleft of the window showed "Sid Meier's Civilization V (DX9)".

    While i have been playing it in the DX10 mode for many hours previously.

    Went to my steam folder itself and started the Launcher manually, and chose the DX10 option, again it shows the DX9 in top left corner of screen.
    Is this a display bugg or something and im really running the DX10 build, or is something being bugging out on my end and DX10 doesnt want to run?
     
  2. JoxerNL

    JoxerNL Warlord

    Joined:
    Oct 2, 2010
    Messages:
    192
    And it gets more interesting o.o
    So i start the launcher, right click it to make a desktop shortcut for the DX10/11 one.
    My computer asks as usuall permission if i want to let steam "go ahead", annoyed i clicked cancell... and lo and behold, the game starts up in DX10/11 mode without a problem.

    Im confused now o.O

    Edit : it keeps getting better...
    DX9 = seeying the scenario's from the DLC.
    DX11 = Not even a "Scenario's" option.
    What the frell...
     
  3. JoxerNL

    JoxerNL Warlord

    Joined:
    Oct 2, 2010
    Messages:
    192
    So i got to installing Civ V again.
    Open the game on steam and instead of getting the "Launcher" it just opens up the DX9 version of the game. ( have been playing DX11 version since release)

    Went to steam folder and opened the Launcher manually, chose the "Recommended" DX10/11 one and it booted up... the DX9 version of the game.

    This time i opened launcher again, chose the "Recommended" DX10/11 option and denied steam anything (vista asks if i want to allow steam access).
    It now opens DX11 version of civ 5 BUT... NO DLC's loaded.

    Anyone know a fix to this cause this is rediculous...

    Any advice/help greatly appreciated.
    -J

    edit : before anyone asks : DX11 version runs fine without any problems, just no DLC because of steam not getting access, but if i give it access it loads the DX9 version... :(

    edit 2 : tried validating game cache, didn't fix, tried re-installing, didn't fix.
     

Share This Page