Locked Production Focus - Cannot change to Default, Food, etc.

Kevin J

Hewer of Wood
Joined
Oct 31, 2005
Messages
345
Location
Nova Scotia
As the title says: city focus gets stuck on production focus.

I'm playing beta 6. Using no mods but TBC.

If I set a city to production focus, it's permanent - there is no going back to default, or any other focus. The UI will show another focus if I click on it, but none of the workers move around. If I leave a city then go back to it, it will still be on production focus, with no way to change it.

Another bug: In beta 5, all the city production screens were mangled, not allowing selection of any production. This still happens on beta 6 after loading a savegame from within an existing game - things are fine until a build completes, then it looks much like it did on beta 5, where you were unable to select production. This only happens when loading a save-game from within a game - if you exit to the main menu then load from there, things work as per normal.

I've also noted when loading a save game from within a TBC mod game, it will list non-modded saves and allow you to load them, but they will not function.

However, when you load from the main menu after selecting mods, it only allows appropriate save games (i.e. saves made with the TBC mod). Is there perhaps a flag in the savegame to indicate that it needs such-and-such mods? If so, I'd assume either those flags are missing or the game is not reading them.

Additonal: India's civ traits aren't updated as indicated on your blog. Not a bug though, just not yet implemented :D
 

Thalassicus

Bytes and Nibblers
Joined
Nov 9, 2005
Messages
11,057
Location
Texas
Changing focus and Gandhi's trait are working correctly for me. There might have been a bug in b6 I somehow fixed in b7, or maybe I forgot to document something correctly. Try updating to b7 and double-check the list on the Reporting Bugs info to see if that fixes the problems. If Gandhi's trait doesn't show up correctly it's likely a cache issue. The city UI thing sounds like a cache issue or incompatibility with another mod.

If you still encounter the city-focus problem after updating and clearing cache, could you describe more about where it occurs? If you found your first city, does the focus get frozen? Do any error messages appear in the tuner (bottom of Reporting Bugs info)?
 

Kevin J

Hewer of Wood
Joined
Oct 31, 2005
Messages
345
Location
Nova Scotia
Changing focus and Gandhi's trait are working correctly for me. There might have been a bug in b6 I somehow fixed in b7, or maybe I forgot to document something correctly. Try updating to b7 and double-check the list on the Reporting Bugs info to see if that fixes the problems. If Gandhi's trait doesn't show up correctly it's likely a cache issue. The city UI thing sounds like a cache issue or incompatibility with another mod.

If you still encounter the city-focus problem after updating and clearing cache, could you describe more about where it occurs? If you found your first city, does the focus get frozen? Do any error messages appear in the tuner (bottom of Reporting Bugs info)?

Haven't had a chance to play for awhile, sorry I didn't report back.

I'm going to clear the cache and download the newest beta. I assume things should work, if not, I'll try to document the bug if it reoccurs. Only using your TBC mod so there shouldn't be mod incompatibilities.
 

Kevin J

Hewer of Wood
Joined
Oct 31, 2005
Messages
345
Location
Nova Scotia
Everything works after clearing the cache and downloading the new version.

Finally played through a full game - first one with your mod since the march patch. I gotta say, the AI seems much more challenging than before - the boost to AI units early on makes early conquering a lot more challenging. Really enjoying the mod!
 
Top Bottom