1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. We have selected the winners of the Old World random draw and competition. For the winning entries, please check this thread.
    Dismiss Notice

Not my civ anymore!

Discussion in 'Civ4 - Legends of Revolution' started by OverlordDude, Mar 9, 2013.

  1. OverlordDude

    OverlordDude Chieftain

    Joined:
    Mar 9, 2013
    Messages:
    2
    I've been playing this mod for a while and I absolutely love it, but I just encountered one of the strangest and most frustrating bugs I've ever seen.

    I am playing the Rhye 50 Civ Earth scenario that starts with only China, Egypt, Sumeria, and India. I started as Sumeria, but never really got anywhere and had a lot of unlucky battles with Barbarians. I lost my second city nearly immediately and all my defenses seemed to refuse to put up a fight to the barbarians. My capital was taken and I was destroyed around 1000 BC

    At this point I took over the Babylonians who had emerged in Korea from the barbarian city, Goth, the same turn I was destroyed. I've never had this happen before so maybe this was also a bug but it did it for me without asking or anything. This isn't my main issue though, but maybe it's related. In any case, the Babylonians were a lot better off than I was. So I made the best of my second life. I made fairly quick work of China with the large army I was provided by the Babylonian "revolution" and had them down to 1 single city within a few turns. When I finally took the last Chinese holdout, I saved and quit, because it was 3:00 in the morning and I had school the next morning.

    Today when I loaded my game It just gave me the "You have been defeated" message. When I proceed to the end-game score summary, It says I'm Qin Shi Huang! So I tried loading an earlier save, and saw I was still China. I even tried my autosaves from when I should have still been Sumeria, and I was China.

    What's going on? I need answers? I'm so confused...
     
  2. OverlordDude

    OverlordDude Chieftain

    Joined:
    Mar 9, 2013
    Messages:
    2
    Hey, guys! I know I ended my last post somewhat sarcastically, but I'm serious about my problem! Doe anyone know about this glitch? Is this just a LoR problem or should I ask in the general forums?
     
  3. Imp. Knoedel

    Imp. Knoedel Simperator Knoedel

    Joined:
    Nov 11, 2011
    Messages:
    8,832
    Location:
    The cooler Germany
    Maybe load up the relevant save? Personally I have never switched civs mid-game yet so I don't know how well it works.
     

Share This Page