1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. We have selected the winners of the Old World random draw and competition. For the winning entries, please check this thread.
    Dismiss Notice
  3. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

One or more player options are invalid - MP

Discussion in 'Civ6 - Technical Support' started by Tony Rodd, Nov 27, 2017.

  1. Tony Rodd

    Tony Rodd Chieftain

    Joined:
    Nov 27, 2017
    Messages:
    3
    Gender:
    Male
    Hi there

    I've been getting the below message when in the multiplayer hosting room and can't click "ready":
    "one or more player options are invalid"

    There are 3 human players
    All have the same version of Civ
    All have the same DLC and the DLC active
    It has happened to 2 of the 3 players
    Once the message comes up, you can't get rid of it
    Once the message is up, you can't click (or unclick) the "ready" button
    It seems to come up once someone has chosen a Civ or a difficulty

    We resolved this by having another player host, but I'd like to fix the issue ideally.

    Any thoughts?
     
  2. oodvboo

    oodvboo Chieftain

    Joined:
    Jan 14, 2018
    Messages:
    1
    Gender:
    Male
    I'm having the same issue. Any luck?
     
  3. Tony Rodd

    Tony Rodd Chieftain

    Joined:
    Nov 27, 2017
    Messages:
    3
    Gender:
    Male
    Kinda...Firstly, make sure there are no mods or DLC turned on unless everyone has it.

    Next, don't select your Civ, change the difficulty or do anything else until all players have joined. Then, once all in, make the choices and changes and you should be fine
     
  4. N1David

    N1David Chieftain

    Joined:
    Jul 21, 2021
    Messages:
    1
    Gender:
    Male
    Bumping this to ask for help. Started getting this on Mac: 2 player game, identical versions and DLC. Game runs fine during first session, but when Player 2 joins the saved game the next time, one computer player is missing altogether and another is showing with a blank name. Player 1 (Host) sees everything normally. P2 cannot click Ready and so we cannot restart the game. No tweaking of difficulty, civs etc, Host has done nothing before P2 joins. Guess it could just be a corrupted game file, but odd that it should happen to one player and not the other. Trying any of the available Autosaves does not make a difference.
     

Share This Page