Preparing the v1.17 Release

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
We are now very close to the release of DoC v1.17.

I have completed all the features I wanted to include in this version, and addressed all the issues that I am aware of at this point. Still, many changes have been introduced over the course of development of this version, so I want to make sure there are no significant bugs. So even though the mod seems very stable to me right now, I want to take some time to let people play on the current state of the code before releasing v1.17 for real.

For that purpose, I have released DoC v1.16.7. You can download it in full here, along with patches from v1.16.6 and v1.16.0. There are no further gameplay or balance changes planned between this and v1.17.0, and ideally nothing much will need to be changed until the v1.17.0 release. However, I will of course address any bugs or balance issues that are reported in the meantime. I anticipate this time period to last at least 2-3 weeks.

While this is going on, I have some other work to do before v1.17 can be released, such as updating pedia entries, loading screen hints, the list of features, and small todos for the mod modules.

But if nothing major goes wrong, I am fairly confident that I can release DoC v1.17 some time in November.
 

DanLT3

Warlord
Joined
May 12, 2010
Messages
195
Location
Sweden
After installing patch 1.16.7 my game will not start any more. I get several python exceptions. I tried with both zip files.
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
What were you using before applying the patch? It is intended only for 1.16.6.
 

DanLT3

Warlord
Joined
May 12, 2010
Messages
195
Location
Sweden
I used 1.16.6 before. Tried the 1.16.6 -> 1.16.7 patch first. And secondly the 1.16.0. to 1.16.7 patch. Both failed with same python error at startup.
 
  • Like
Reactions: Amo

ThreeBlackSevens

Chieftain
Joined
Nov 10, 2019
Messages
63
Location
Canada
I also had the same issue - had to just download the whole 1.16.7 thing directly and replace the old one. I didn't try 1.16.0-1.16.7 though, just 1.16.6-1.16.7
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
I see. The patches are automatically created, so maybe the script that creates them missed something. I'll have a look.

You can of course always download the full installer, it has no downsides besides the larger download.
 

J. D. Perón

Chieftain
Joined
Nov 15, 2020
Messages
6
Después de instalar el parche 1.16.7, mi juego ya no se iniciará. Recibo varias excepciones de python. Probé con ambos archivos zip.
Tengo el mismo problema! Instalé el parche 1.16.7 y el mod dejó de funcionar! Al iniciar me aparecen múltiples errores de python hasta que finalmente se cierra automáticamente. Cuál podrá ser el problema?
 

J. D. Perón

Chieftain
Joined
Nov 15, 2020
Messages
6
I can't run de mod anymore since the 1.16.7 patch! I've also tried to install it with the full installer but when it becomes to launch a lot of "python errors" show up in my screen and finally the game shuts down. Any idea? Help me please Loreth!
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
I will look into fixing the patch in a bit. When using the full installer, did you delete the existing mod first?
 

J. D. Perón

Chieftain
Joined
Nov 15, 2020
Messages
6
I will look into fixing the patch in a bit. When using the full installer, did you delete the existing mod first?
Thank you for answering! I did what you told me to... I uninstalled the whole MOD and installed it again with the full installer. It runs now but I have another problem. When I select "Play a scenario" now I can't fin the maps!. I can only see "WBQuickSave"!. The path I always choose fot installing is "C:\Program Files (x86)\Steam\steamapps\common\Sid Meier's Civilization IV Beyond the Sword\Beyond the Sword\Mods\RFC Dawn of Civilization". I've never had problems in the past. I'm kinda lost now!
 

Attachments

  • Imagen de WhatsApp 2022-10-29 a las 10.55.27.jpg
    Imagen de WhatsApp 2022-10-29 a las 10.55.27.jpg
    108.8 KB · Views: 32

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
That's part of the changes that happened during the development until 1.16.7. Now instead you start a game by selecting the "Play Now" button, and then from there you can choose your scenario and all the other choices you would have made from the Scenario option.
 

J. D. Perón

Chieftain
Joined
Nov 15, 2020
Messages
6
That's part of the changes that happened during the development until 1.16.7. Now instead you start a game by selecting the "Play Now" button, and then from there you can choose your scenario and all the other choices you would have made from the Scenario option.
Allright then! Thanks again!
 

Ecthy

Warlord
Joined
Feb 28, 2017
Messages
252
Playing recently as Japan, England was still way ahead in tech, while most others were not. Is this really what we want?
 

Attachments

  • Oda Nobunaga AD-1904-July Turn 1193.CivBeyondSwordSave
    2.3 MB · Views: 12

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
What was the starting year for this game?
 

Ecthy

Warlord
Joined
Feb 28, 2017
Messages
252
600 AD.

With civs now being less prone to trading techs, the Japanese UP becomes a lot less helpful.
 

Leoreth

Blue Period
Moderator
Joined
Aug 23, 2009
Messages
36,163
Location
東京藝術大学
Update on the patches: in case anyone still cares, unfortunately patches won't work for v1.16.7 because it also requires some files to be deleted. So unfortunately it will always be necessary to install the full mod from scratch.
 

hendriksen

Chieftain
Joined
Sep 6, 2008
Messages
32
I'm now loading a game of the Polish on 3000 BC start, will let you know how that goes👍 I like to change the leader name and CIV name in the menu whenever I start a game. On this version however I get a bunch of Python exceptions if I do that, when I leave the leader and CIV name, adjective et cetera intact it loads just fine.

Is there a list of changes from version 1.16 to 1.17?

When I want to roll back from version 1.17 to 1.16. Can I use the below link that is in your signature?

Very cool that you are already thinking about version 1.18 even when 1.17 is not officially released. We are blessed which you as a very active developer for this game!!😎
 
Top Bottom