1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Test of Time - Midgard Scenario - Glitch?

Discussion in 'Civ2 - General Discussions' started by Hemrawc, Jan 29, 2019.

  1. Hemrawc

    Hemrawc Chieftain

    Joined:
    Jan 29, 2019
    Messages:
    2
    Gender:
    Male
    I just recently re-installed my copy of Test of Time following Catfish's installation guide (thank you BTW). I have it running on a 64 bit Windows 10 computer. I started the Midgard scenario and noticed that the Crag Wolf has unlimited movement. I'm assuming this is a glitch. I installed the events patch for the Midgard game as mentioned on Catfish's website.

    Has anyone else run into this before?
    Can I expect this glitch for all alpine units?
    Did I possibly install the game incorrectly?

    Thank you.
     
  2. vanarya

    vanarya Chieftain

    Joined:
    Feb 3, 2019
    Messages:
    1
    I also ran into this issue. It turns out that this is due to the "Movement multipliers" under Extra cosmic parameters of the patch project, as it seems the default (for all alpine units, roads, and rivers) is unlimited movement if you haven't set it to a different value under COSMIC2 in rules.txt.

    Because enabling it means you have to change the rules.txt for each version you want to play (original, midgard, etc), I just disabled it. If you uncheck the Movement multipliers box in the TOTPP launcher, the movement will behave normally.

    Edit: looks like it's a recent bug, see /threads/road-and-river-movement-bug.635829/
     
    Last edited: Feb 3, 2019
  3. Hemrawc

    Hemrawc Chieftain

    Joined:
    Jan 29, 2019
    Messages:
    2
    Gender:
    Male
    Thank you vanarya!

    I completely reinstalled the game by following the aforementioned Test of Time Installation Guide by Catfish. On step #5 I installed the Test of Time Patch by TheNamelessOne. I then clicked on the TOTLauncher.exe a second time and then deselected the "Movement multipliers" under the "Extra cosmic parameters" section as you described. Subsequently, I clicked the "Save and launch" button. Although the launcher failed to start civ2.exe, I simply started the .exe file manually and now the movement works correctly. I greatly appreciate your quick response! :goodjob:
     

Share This Page